• AtCoder Beginner Contest 045 C


    C - たくさんの数式 / Many Formulas


    Time limit : 2sec / Memory limit : 256MB

    Score : 300 points

    Problem Statement

    You are given a string S consisting of digits between 1 and 9, inclusive. You can insert the letter + into some of the positions (possibly none) between two letters in this string. Here, + must not occur consecutively after insertion.

    All strings that can be obtained in this way can be evaluated as formulas.

    Evaluate all possible formulas, and print the sum of the results.

    Constraints

    • 1≤|S|≤10
    • All letters in S are digits between 1 and 9, inclusive.

    Input

    The input is given from Standard Input in the following format:

    S
    

    Output

    Print the sum of the evaluated value over all possible formulas.


    Sample Input 1

    Copy
    125
    

    Sample Output 1

    Copy
    176
    

    There are 4 formulas that can be obtained: 1251+2512+5 and 1+2+5. When each formula is evaluated,

    • 125
    • 1+25=26
    • 12+5=17
    • 1+2+5=8

    Thus, the sum is 125+26+17+8=176.


    Sample Input 2

    Copy
    9999999999
    

    Sample Output 2

    Copy
    12656242944
    题意:把一个数用不同的切割方法 把每种切割后的数累加
    题解:用二进制转化,用&符号判断切割的位置
    #include<bits/stdc++.h>
    using namespace std;
    int main()
    {
        string s;
        cin>>s;
        int n=s.size();
        int m=1<<(n-1);
        long long ans=0;
        for(int i=0;i<m;i++)
        {
            long long t=s[0]-'0';
            for(int j=0;j<n;j++)
            {
                if(j==n-1||i&1<<j)      //切的方法 
                {
                    ans+=t;
                    t=0;
                    if(j==n-1)  break;
                }
                t*=10;
                t+=s[j+1]-'0';
            }
        }
        cout<<ans<<endl;
    }
    漫天星辰,繁华时下。心中冷淡,一笑奈何。
  • 相关阅读:
    Master公式计算递归时间复杂度
    对数器的使用
    HTML翻转菜单练习
    剑指offer题目解答合集(C++版)
    HTML---仿网易新闻登录页
    两个有序数组中的中位数以及求第k个最小数的值
    算法之重建二叉树
    AFNetWorking 上传功能使用及源码分析
    图片Alpha预乘的作用[转]
    C#/.NET 学习之路——从入门到放弃
  • 原文地址:https://www.cnblogs.com/Scalpel-cold/p/7263842.html
Copyright © 2020-2023  润新知