• 浙大pat---1036 Boys vs Girls (25)


    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade~F~-grade~M~. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA
    题目解析:
    这题就考基础的模拟,使用结构体封装并手动找出最大最小值即可,水题!
    #include <iostream>
    #include <vector>
    #include <string.h>
    #include <algorithm>
    #define MAX 101
    using namespace std;
    struct student
    {
        string name;
        char gender;
        string id;
        int grade;
    };
    vector<student> male;
    vector<student> female;
    int main() {
        bool flag = false;
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            student temp;
            cin>>temp.name;
            cin>>temp.gender;
            cin>>temp.id>>temp.grade;
            if(temp.gender=='M')
            {
                male.push_back(temp);
            }
            else{
                female.push_back(temp);
            }
        }
        int max = -1;
        int mim = MAX;
        int female_index;
        int male_index;
        //female highest
        for(int i=0;i<female.size();i++)
        {
            if(max<female[i].grade)
            {
                max = female[i].grade;
                female_index = i;
            }
        }
        for(int i=0;i<male.size();i++)
        {
            if(mim>male[i].grade)
            {
                mim = male[i].grade;
                male_index = i;
            }
        }
        if(max == -1)
        {
            cout<<"Absent"<<endl;
            flag = true;
        }
        else{
            cout<<female[female_index].name<<" "<<female[female_index].id<<endl;
        }
        if(mim == MAX)
        {
            cout<<"Absent"<<endl;
            flag = true;
        }
        else{
            cout<<male[male_index].name<<" "<<male[male_index].id<<endl;
        }
        if(flag)
        {
            cout<<"NA"<<endl;
        }
        else{
            cout<<female[female_index].grade - male[male_index].grade<<endl;
        }
    
        return 0;
    }
    

      

  • 相关阅读:
    k8s 节点的 NodeAffinity 使用
    template 与 host , item trigger的关系
    mysql 性能优化思路
    nginx 配sorry page
    修改tomcat JVM 大小 jdk--目录修改
    (转)MySQL慢查询分析优化 + MySQL调优
    注册表操作 Microsoft.Win32.Registry与RegistryKey类
    C#(99):WCF之.NET Remoting通讯
    CallContext线程数据缓存-调用上下文
    C#(99):JSON与对象的序列化与反序列化
  • 原文地址:https://www.cnblogs.com/SK1997/p/9384292.html
Copyright © 2020-2023  润新知