• 浙大pat甲级题目---1012. The Best Rank (25)


    To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

    For example, The grades of C, M, E and A - Average of 4 students are given as the following:

    StudentID  C  M  E  A
    310101     98 85 88 90
    310102     70 95 88 84
    310103     82 87 94 88
    310104     91 91 91 91
    

    Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

    Input

    Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

    Output

    For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

    The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

    If a student is not on the grading list, simply output "N/A".

    Sample Input

    5 6
    310101 98 85 88
    310102 70 95 88
    310103 82 87 94
    310104 91 91 91
    310105 85 90 90
    310101
    310102
    310103
    310104
    310105
    999999
    

    Sample Output

    1 C
    1 M
    1 E
    1 A
    3 A
    N/A
    

     题目大意:是一道模拟题,意思是让我们找出每个人最佳的排名

    题目思路:这道题我用的是最笨的办法。首先定义一个结构体,存放学生id,四门成绩以及最佳排名,这道题的主要目的就是填充每个学生的最佳排名变量。我主要是用map<string,student>来存储每个学生(方便用于之后查找)然后定义四个数组分别存放四门课,对四个数组分别排名,然后针对每个待查找的学生,分别查看他们每门成绩的排名,再排序,找到排名最优的。具体看代码吧。

    #include <iostream>
    #include <vector>
    #include <algorithm>
    #include<map>
    using namespace std;
    int aa[2005],cc[2005],mm[2005],ee[2005];
    enum subject
    {
        AA=0,
        CC,
        MM,
        EE
    };
    struct student
    {
        string id;
        int c,m,e,a;    // four garde
        int max;    //best grade
        subject symbol;
    };
    bool compare(int a,int b)
    {
        return a>b; //升序排列,如果改为return a>b,则为降序
    }
    int check(int *t,int score,int n)
    {
        for(int i=0;i<n;i++)
        {
            if(t[i]==score)
                return i+1;
        }
    }
    
    void getSymbol(student &i,int n)
    {
        int a,c,m,e;
        int mim=1000;
        a=check(aa,i.a,n);
        c=check(cc,i.c,n);
        m=check(mm,i.m,n);
        e=check(ee,i.e,n);
        if(a<mim)
        {
            mim=a;
            i.symbol=AA;
            i.max=mim;
        }
        if(c<mim)
        {
            mim=c;
            i.symbol=CC;
            i.max=mim;
        }
        if(m<mim)
        {
            mim=m;
            i.symbol=MM;
            i.max=mim;
        }
    
        if(e<mim)
        {
            mim=e;
            i.symbol=EE;
            i.max=mim;
        }
    
    }
    int main()
    {
        int m,n;
        int i;
        map<string,student> rank;
        subject symbol;
        string id,search;
        id.resize(7);
        search.resize(7);
        int C,M,E,A;
    
        int max=-1;
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
        {
            max=-1;
            student s;
            scanf("%s",&id[0]);
            scanf("%d%d%d",&C,&M,&E);
            A=(C+M+E)/3;
            //if(judge(aa,A,n))
                aa[i]=A;
            //if(judge(cc,C,n))
                cc[i]=C;
            //if(judge(mm,M,n))
                mm[i]=M;
            //if(judge(ee,E,n))
                ee[i]=E;
            s.a=A;s.c=C;s.e=E;s.m=M;s.id=id;
    
            s.max=max;
            s.symbol=symbol;
            rank[id]=s;
            //cout<<symbol<<" "<<s.max<<endl;
        }
        sort(aa,aa+n,compare);
        sort(cc,cc+n,compare);
        sort(mm,mm+n,compare);
        sort(ee,ee+n,compare);
        for(i=0;i<m;i++)
        {
            scanf("%s",&search[0]);//学会这种输入string的办法
            if(rank.find(search)==rank.end())
                cout<<"N/A"<<endl;
            else
            {
                getSymbol(rank[search],n);
                if(rank[search].symbol==AA)
                {
                    cout<<rank[search].max<<" ";
                    cout<<"A"<<endl;
                }
                else if(rank[search].symbol==CC)
                {
                    cout<<rank[search].max<<" ";
                    cout<<"C"<<endl;
                }
                else if(rank[search].symbol==MM)
                {
                    cout<<rank[search].max<<" ";
                    cout<<"M"<<endl;
                }
                else if(rank[search].symbol==EE)
                {
                    cout<<rank[search].max<<" ";
                    cout<<"E"<<endl;
                }
            }
    
        }
        return 0;
    }
  • 相关阅读:
    汇编语言实验4
    汇编语言实验3
    汇编语言实验2
    汇编语言实验1
    汇编语言学习心得
    Java 之不小心修改对象值
    实验九 根据材料编程
    实验5 编写、调试具有多个段的程序
    实验四 [bx]和loop的使用
    ASCII(侵权删)
  • 原文地址:https://www.cnblogs.com/SK1997/p/8583067.html
Copyright © 2020-2023  润新知