• 1028-Digital Roots


    描述

     

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    输入

     

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

    输出

     

    For each integer in the input, output its digital root on a separate line of the output.

    样例输入

    24

    39

    0

    样例输出

    6

    3

    #include<iostream>
    #include<string>
    using namespace std;
    int main()
    {  
        string str;
        while(cin>>str&&str!="0"){
                
            int num=0;                  
            for(int i=0;i<str.length();i++)
            {         
                       num+=str[i]-'0';
                       if(num>9)
                          num=num/10+num%10;          
            }    
            cout<<num<<endl;                      
        }   
        return 0;
    }  
    

      

  • 相关阅读:
    字符串提取数字/汉字/英文字母
    CHARINDEX,PATINDEX,STUFF函数
    raiserror的用法
    数据库备份与还原(通过命令)
    查询某个字段属于哪些表
    设备驱动基础1:设备模型之总线,驱动,设备
    设备模型之kobject,kset及其关系
    模拟电路创新设计
    cdev、udev
    PCB阻抗调节
  • 原文地址:https://www.cnblogs.com/Rosanna/p/3436563.html
Copyright © 2020-2023  润新知