• ZOJ 1610 Count the Colors(线段树/暴力)


    Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

    Your task is counting the segments of different colors you can see at last.


    Input

    The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

    Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

    x1 x2 c

    x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

    All the numbers are in the range [0, 8000], and they are all integers.

    Input may contain several data set, process to the end of file.


    Output

    Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

    If some color can't be seen, you shouldn't print it.

    Print a blank line after every dataset.


    Sample Input

    5
    0 4 4
    0 3 1
    3 4 2
    0 2 2
    0 2 3
    4
    0 1 1
    3 4 1
    1 3 2
    1 3 1
    6
    0 1 0
    1 2 1
    2 3 1
    1 2 0
    2 3 0
    1 2 1


    Sample Output

    1 1
    2 1
    3 1

    1 1

    0 2
    1 1

    思路:我这个星期一直在打线段树,但这道题就不知道为什么过不了,用暴力就过了,我好难受...

    #include <cstdio>
    #include <iostream>
    #include <string>
    #include <cstring>
    #include <cmath>
    #include <algorithm>
    #include <queue>
    #include <vector>
    #include <map>
    using namespace std;
    #define ll long long
    
    int n, l, r, c, color[8000 + 8], rmax;
    map<int, int>ans;
    
    int main()
    {
        std::ios::sync_with_stdio(0);
        cin.tie(0);
        cout.tie(0);
        while(cin>>n)
        {
            ans.clear();
            fill(color, color + 8008, -1);
    
            rmax = -1;
            for(int i = 0; i < n; i++)
            {
                cin >> l >> r >> c;
                rmax = max(r, rmax);
                for(int j = l; j < r; j++)
                {
                    color[j] = c;
                }
            }
            for(int i = 0; i < rmax; i++)
            {
                if(color[i] != -1)
                {
                    if(!ans[color[i]])
                        ans[color[i]] = 1;
                    else if(i && ans[color[i]] && color[i] != color[i - 1])
                        ans[color[i]]++;
                }
    
            }
            map<int, int>::iterator i;
            for(i = ans.begin(); i != ans.end(); i++)
                cout << i->first << " " << i->second <<'
    ';
            cout << '
    ';
        }
        return 0;
    }
  • 相关阅读:
    LeetCode "Palindrome Partition II"
    LeetCode "Longest Substring Without Repeating Characters"
    LeetCode "Wildcard Matching"
    LeetCode "Best Time to Buy and Sell Stock II"
    LeetCodeEPI "Best Time to Buy and Sell Stock"
    LeetCode "Substring with Concatenation of All Words"
    LeetCode "Word Break II"
    LeetCode "Word Break"
    Some thoughts..
    LeetCode "Longest Valid Parentheses"
  • 原文地址:https://www.cnblogs.com/RootVount/p/11436768.html
Copyright © 2020-2023  润新知