• POJ 2923 【01背包+状态压缩/状压DP】


    题目链接

    Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:
    
    At their old place, they will put furniture on both cars.
    Then, they will drive to their new place with the two cars and carry the furniture upstairs.
    Finally, everybody will return to their old place and the process continues until everything is moved to the new place.
    Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.
    
    Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.
    
    Input
    The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.
    
    Output
    The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.
    
    Sample Input
    2
    6 12 13
    3 9 13 3 10 11
    7 1 100
    1 2 33 50 50 67 98
    Sample Output
    Scenario #1:
    2
    
    Scenario #2:
    3
    

    【题意】:两辆车n个物品,每个物品有体积,两辆车也有体积,要求把物品全部运走最少需要多少次,每次每辆车运送的物体总体积不得大于车的体积。
    【分析】:
    1.掌握位运算的运算法优先级别很重要
    2.掌握基本位运算
    (1).判断是否为0 if((S&1<<i)==0)
    (2).将第i位置1 S|1<<i
    (3).将第i位置0 S&~(1<<i)
    3.要有状态的思想 每次是对状态进行操作


    预处理所有合法组合...
    从合法组合中选取最小的次数。


    #include<cstdio>
    #include<string>
    #include<cstdlib>
    #include<cmath>
    #include<iostream>
    #include<cstring>
    #include<set>
    #include<queue>
    #include<algorithm>
    #include<vector>
    #include<map>
    #include<cctype>
    #include<stack>
    #include<sstream>
    #include<list>
    #include<assert.h>
    #include<bitset>
    #include<numeric>
    #define debug() puts("++++")
    #define gcd(a,b) __gcd(a,b)
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define fi first
    #define se second
    #define pb push_back
    #define sqr(x) ((x)*(x))
    #define ms(a,b) memset(a,b,sizeof(a))
    #define sz size()
    #define be begin()
    #define pu push_up
    #define pd push_down
    #define cl clear()
    #define lowbit(x) -x&x
    #define all 1,n,1
    #define rep(i,n,x) for(int i=(x); i<(n); i++)
    #define in freopen("in.in","r",stdin)
    #define out freopen("out.out","w",stdout)
    using namespace std;
    typedef long long LL;
    typedef unsigned long long ULL;
    typedef pair<int,int> P;
    const int INF = 0x3f3f3f3f;
    const LL LNF = 1e18;
    const int maxn =  1e5 + 5;
    const int maxm = 1e6 + 10;
    const double PI = acos(-1.0);
    const double eps = 1e-8;
    const int dx[] = {-1,1,0,0,1,1,-1,-1};
    const int dy[] = {0,0,1,-1,1,-1,1,-1};
    const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    /*
    总的复杂度是O(VNK)
    3
    5 10 2
    1 2 3 4 5
    5 4 3 2 1
    5 10 12
    1 2 3 4 5
    5 4 3 2 1
    5 10 16
    1 2 3 4 5
    5 4 3 2 1
    */
    int n,m,K;
    #define S 100000
    #define M 200000
    int state[1030];
    int dp[1030];
    bool vis[1005];
    int v1,v2,tot;
    int c[12];
    bool ok(int x)//判断一种状态是否可行(可以一次运走)
    {
        int sum = 0;
        ms(vis,0);
        vis[0] = 1;
        for (int i = 0;i < n;i++)
        {
            if ((x>>i)&1)
            {
                sum += c[i];
                for (int j = v1;j >= c[i];j--) //这个真的非常巧妙 开始看半天都不懂,自己模拟一遍才懂
                {                              //比如说此状态有c1、c2、c3,3个体积,第一次操作把体积c1标记为1,
                      if (vis[j-c[i]])         //第二次操作把c2和c1+c2两种体积标记为1,第三次把c3和前面的组合标记为1,
                        vis[j] = 1;            //最后这些体积能组合成的所有体积就都被标记成了1
                }
            }
        }
        if (sum > v1+v2 )//装不下
            return 0;
        //总体积小不代表一定装得下,拆分成2份要2份都装得下
        for (int i = 0;i <= v1;i++)
        {
            if (vis[i] && sum-i <= v2)//如果存在(i,sun-i)这样的组合
                return 1;           //满足i可以被v1装下(前面for循环是对于v1的,vis[i]表示体积i可以被v1装下),sun-i可以被v2装下
        }
        return 0;
    }
    void init()//初始化找到满足条件的状态
    {
        tot = 0;
        for (int i = 1; i < (1<<n); i++)
        {
            dp[i] = INF;
            if (ok(i))
                state[tot++] = i;
        }
    }
    int main()
    {
        int T;
        cin>>T;
        int oo = 0;
        while (T--)
        {
            cin>>n>>v1>>v2;
            for (int i = 0;i < n;i++)
                scanf("%d",&c[i]);
            init();
            int V = (1<<n) - 1;//V是n个1的二进制数
            dp[0] = 0;  //没有物品当然是0次运走
            for (int i = 0;i < tot;i++)
            {
                for (int j = V;j >= 0;j--)
                {
                    if (dp[j] == INF)
                        continue;    //原版的背包是dp[j] = min(dp[j],dp[j-c[i]]+w[i])
                                      //但是显然二进制不好表示减,但是可以用|抽象加
                                      //这就相当于背包改版成dp[j+c[i]] = min(dp[j+c[i]],dp[j] + w[i])
                    if ((j&state[i])==0) //当然2种状态不能有交集
                    {
                        dp[j|state[i]] = min(dp[j|state[i]] ,dp[j] + 1);
                    }
                }
            }
            printf("Scenario #%d:
    %d
    ",++oo,dp[V]);
            if (T) puts("");
        }
        return 0;
    }
    // dp[j|s[i]] = min(dp[j|s[i]], dp[j]+1);//在运输了状态j上,在运输s[i], 变成状态j|s[i]
    //如果dp[i-1][j-w[i]]已经出现了(就是说如果存在了重量j-w[i],我只需要填上重量w[i]就可以形成j),那么dp[i-1][j]就可以组成。
    //如果满足q[i]这种组合的搬运,就需要增加一次搬运dp[j]+1
    //然后两个用或运算合起来,表示一次两车运的物体。(注意:要把载最重的车能载的情况也看作是一次合)
    ////vis为第一个背包能装的情况  //x为状压后的一个集合  //在运输了状态j上,在运输s[i], 变成状态j|s[i]
    ////01背包因为减法不好用2进制表示,因此选择加法的DP
    
    
  • 相关阅读:
    第四节:前端自动化准备和详细配置(NVM、NPM/CNPM、NodeJs、NRM、WebPack、Gulp/Grunt、Git/SVN)
    第二十三节: EF性能篇(三)之基于开源组件 Z.EntityFrameWork.Plus.EF6解决EF性能问题
    第三节:一些指令总结(Nuget、)
    第十七节:易混淆的概念(静态和非静态、拆箱和装箱)
    Java使用Log4记录日志
    Java读取xml
    C# int.ToString() 常用参数说明
    WebAPI获取客户端请求数据
    Zend Studio获取永久使用权
    template.js 模版内调用外部JS方法
  • 原文地址:https://www.cnblogs.com/Roni-i/p/9048922.html
Copyright © 2020-2023  润新知