• POJ 3628 Bookshelf 2【背包型DFS/选or不选】


    Bookshelf 2
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11105   Accepted: 4928

    Description

    Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

    FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

    To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

    Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

    Input

    * Line 1: Two space-separated integers: N and B
    * Lines 2..N+1: Line i+1 contains a single integer: Hi

    Output

    * Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

    Sample Input

    5 16
    3
    1
    3
    5
    6

    Sample Output

    1

    Source

    【题意】:现有一个书架,N头牛,农场主想把这些牛放在书架上。但书架是有固定的高度的。现在问你在这些牛之中,其中一些牛的高度加在一块比书架高的最小差值是多少?
    【分析】:
    #include<stdio.h>  
    int cow[20];  
    int b;  
    int n;  
    int ans=99999999;  
    void DFS(int num,int sum)  
    {  
        if(sum>=ans) return;  
        if(num==n)  
        {  
            if(sum>=b) ans=sum;  
            return;  
        }  
        DFS(num+1,sum);  
        DFS(num+1,sum+cow[num]);  
    }  
    int main()  
    {  
        //freopen("input","r",stdin);  
        int i,j,cnt,tmp;  
        int sum;  
        scanf("%d %d",&n,&b);  
        for(i=0;i<n;i++)  
            scanf("%d",&cow[i]);  
        DFS(0,0);  
        printf("%d",ans-b);  
        return 0;  
    }  
    View Code
  • 相关阅读:
    WPF xaml中列表依赖属性的定义
    查询英语单词
    WPF 界面如何绑定Command
    C# 获取当前屏幕的宽高和位置
    WPF 列表开启虚拟化的方式
    WPF MVVM UI分离之《交互与数据分离》
    WPF TextBlock IsTextTrimmed 判断文本是否超出
    局部变量表中Slot复用对垃圾回收的影响详解
    ArrayList中的Iterator详解
    oracle
  • 原文地址:https://www.cnblogs.com/Roni-i/p/7966780.html
Copyright © 2020-2023  润新知