• PAT A级 1076 Forwards on Weibo (超详细BFS做法)


    一切杀不死我的,都将使我强大! 

    1076 Forwards on Weibo(30 分)

    Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

    M[i] user_list[i]
    

    where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

    Then finally a positive K is given, followed by K UserID's for query.

    Output Specification:

    For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

    Sample Input:

    7 3
    3 2 3 4
    0
    2 5 6
    2 3 1
    2 3 4
    1 4
    1 5
    2 2 6
    

    Sample Output:

    4
    5
    

    作者: CHEN, Yue

    单位: 浙江大学

    时间限制: 3000 ms

    内存限制: 64 MB

    代码长度限

    #include<iostream>
    #include<vector>
    #include<queue>
    #include<cstring>
    #include<algorithm>
    const int maxn=1010;//最大为1000 
    using namespace std;
    struct Node
    {
    	int id;//用户编号 
    	int layer;//当前搜索的层次 
    };
    vector<Node>map[maxn];//邻接表储存 
    bool vis[maxn] = {false} ;//标记是否入队 
    
    int bfs(int s,int L)
    {
    	int ans=0;//能够转发的最大次数 
    	queue<Node>q;
    	Node start;
    	start.id = s;
    	start.layer = 0;
    	q.push(start);//入队 
    	vis[start.id] = true;//标记已经入队 
    	while (!q.empty())
    	{
    		Node top = q.front();
    		q.pop();//取队首 
    		int u = top.id;//队首用户编号 
    		for (int i=0;i<map[u].size();i++)//遍历当前用户可以传递的其他用户 
    		{
    			Node temp = map[u][i];
    			temp.layer = top.layer + 1;//层次 +1 
    			if (vis[temp.id]==false && temp.layer<=L)//如果没有入队过,也就是没有被访问过,并且层次没有超过,则可以入队。 
    			{
    				q.push(temp);
    				vis[temp.id] = true;//标记已经入队 
    				ans++;//转发次数 +1 
    			}
    		}
    	}
    	return ans;
    }
    
    int main()
    {
    	Node user;
    	int n,L,ID,sum,T,s;
    	cin>>n>>L;
    	for (int i=1;i<=n;i++)
    	{
    		user.id = i;//用户编号赋值 
    		cin>>sum;
    		for (int j=0;j<sum;j++)
    		{
    			cin>>ID;
    			map[ID].push_back(user);
    		}
    	}
    	cin>>T;
    	while (T--)
    	{
    		memset(vis,false,sizeof(vis));
    		cin>>s;
    		int ANS = bfs(s,L);
    		cout<<ANS<<endl;//输出答案就好啦 
    	}
    	return 0;	
    }
  • 相关阅读:
    图论————拓扑排序
    状态压缩DP:蒙德里安的梦想
    差分+贪心:IncDec序列
    三目运算符
    贪心+高精度:国王游戏
    图论——最小生成树:Prim算法及优化、Kruskal算法,及时间复杂度比较
    图论——Floyd算法拓展及其动规本质
    图论——最短路:Floyd,Dijkstra,Bellman-Ford,SPFA算法及最小环问题
    贪心+DFS:引水入城
    网站移动版本开发踩坑实录一
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451451.html
Copyright © 2020-2023  润新知