• 2018 ACM-ICPC 亚洲青岛区域网络赛 A Live Love


    DreamGrid is playing the music game Live Love. He has just finished a song consisting of n notes and got a result sequence A​1​​,A​2​​,...,A​n​​ (A​i​​∈ {PERFECT, NON-PERFECT}). The score of the song is equal to the max-combo of the result sequence, which is defined as the maximum number of continuous PERFECTs in the sequence.

    Formally speaking, max-combo(A)=max { k | k is an integer and there exists an integer i (1≤i≤n−k+1) such that A​i​​=A​i+1​​=A​i+2​​=...=A​i+k−1​​= PERFECT }. For completeness, we define max(∅)=0.

    As DreamGrid is forgetful, he forgets the result sequence immediately after finishing the song. All he knows is the sequence length n and the total number of PERFECTs in the sequence, indicated by m. Any possible score s he may get must satisfy that there exists a sequence A​′​​of length n containing exactly m PERFECTs and (n−m) NON-PERFECTs and max-combo(A​′​​)=s. Now he needs your help to find the maximum and minimum s among all possible scores.

    Input

    There are multiple test cases. The first line of the input contains an integer T (1≤T≤100), indicating the number of test cases. For each test case:

    The only line contains two integers n and m (1≤n≤10​3​​, 0≤m≤10​3​​, m≤n), indicating the sequence length and the number of PERFECTs DreamGrid gets.

    Output

    For each test case output one line containing two integers s​max​​ and s​min​​, indicating the maximum and minimum possible score.

    Sample Input

    5
    5 4
    100 50
    252 52
    3 0
    10 10
    

    Sample Output

    4 2
    50 1
    52 1
    0 0
    10 10
    

    Hint

    Let's indicate a PERFECT as P and a NON-PERFECT as N.

    For the first sample test case, the sequence (P,P,P,P,N) leads to the maximum score and the sequence (P,P,N,P,P) leads to the minimum score.

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    int main()
    {
    	int T;
    	cin>>T;
    	while(T--)
    	{
    		int n,m;
    		cin>>n>>m;
    		if(n==m)
    		   cout<<m<<" "<<m<<endl;
    		else if(m==0)
    		   cout<<"0"<<" "<<"0"<<endl;
    		else 
    		{
    			if(n/m>=2)
                  cout<<m<<" "<<"1"<<endl;
                else 
                {
                	int c = n-m;
                	int s;
                	if(m%(c+1)==0)
                	   s = m/(c+1);
                	else 
                	   s = m/(c+1) + 1;
                	cout<<m<<" "<<s<<endl;
                }
    		}
    	}
    	return 0;
    } 
    
  • 相关阅读:
    第24课 #pragma使用分析
    第23课 #error和#line使用分析
    第22课 条件编译使用分析
    第21课 宏定义与使用分析
    Codeforces Round #142 (Div. 2)B. T-primes
    SPOJ XMAX
    Uva 10036
    Timus 1009. K-based Numbers
    MBLAST
    ROADS
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451415.html
Copyright © 2020-2023  润新知