• How Many Tables (并查集裸模板题)


    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

    Input

    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

    Output

    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

    Sample Input

    2
    5 3
    1 2
    2 3
    4 5
    
    5 1
    2 5

    Sample Output

    2
    4
    #include<iostream>
    using namespace std;
    int fa[10000+10];
    bool Root[10000+10];
    
    int find(int x)
    {
    	return x==fa[x]?x:find(fa[x]);
    }
    
    void Union(int a,int b)
    {
    	int faA = find(a);
    	int faB = find(b);
    	if (faA!=faB)
    	{
    		fa[faA] = faB;
    	}
    } 
    
    int main()
    {
    	int n,m,j,k,i,T,a,b;
    	cin>>T;
    	while (T--)
    	{
    		cin>>n>>m;
    		for (i=1;i<=n;i++)
    		fa[i] = i,Root[i]=false;
    		
    		while (m--)
    		{
    			cin>>a>>b;
    			Union(a,b);		
    		}	
    		for (i=1;i<=n;i++)
    		{
    			Root[find(i)] = true;
    		}
    		int ans=0;
    		for (i=1;i<=n;i++)
    		ans+=Root[i];
    		
    		cout<<ans<<endl;
    	}		
    	
    	return 0;
    }
  • 相关阅读:
    Android 内存剖析 – 发现潜在问题
    Android内存泄漏问题(一)
    Android的事件处理机制详解(二)-----基于监听的事件处理机制
    Android的事件处理机制(一)------基于回调机制的事件处理
    OOA、OOD 和 OOP
    面向对象初识
    Python 2 和 Python 3 的区别
    软件开发规范
    语法分析和词法分析
    循环删除的坑
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451297.html
Copyright © 2020-2023  润新知