• UESTC 1215 (思维题 旋转)


    Secrete Master Plan

    Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
     

    Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form a 2×22×2 matrix, but Fei didn't know the correct direction to hold the sheet. What a pity!

    Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.

    title

    Input

    The first line of the input gives the number of test cases, TT(1T1041≤T≤104). TT test cases follow. Each test case contains 44 lines. Each line contains two integers ai0ai0 and ai1ai1 (1ai0,ai11001≤ai0,ai1≤100). The first two lines stands for the original plan, the 3rd3rd and 4th4th line stands for the plan Fei opened.

    Output

    For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy is either "POSSIBLE" or "IMPOSSIBLE" (quotes for clarity).

    Sample input and output

    Sample InputSample Output
    4
    1 2
    3 4
    1 2
    3 4
    
    1 2
    3 4
    3 1
    4 2
    
    1 2
    3 4
    3 2
    4 1
    
    1 2
    3 4
    4 3
    2 1
    Case #1: POSSIBLE
    Case #2: POSSIBLE
    Case #3: IMPOSSIBLE
    Case #4: POSSIBLE

    Source

    The 2015 China Collegiate Programming Contest
    #include <iostream>
    using namespace std;
    int main()
    {
        int t,a,b,c,d,x,y,z,w,tmp,k=1;
        cin>>t;
        while(t--)
        {
            int flag=0;
            cin>>a>>b>>d>>c;
            cin>>x>>y>>w>>z;
            while (a!=x||b!=y||d!=w||c!=z)
            {
                tmp=a;
                a=b;
                b=c;
                c=d;
                d=tmp;
                flag++;
                if (flag==4)
                break;
            }
            if (flag<4)
            {
                cout<<"Case #"<<k++<<": POSSIBLE"<<endl;
            }
            else
            cout<<"Case #"<<k++<<": IMPOSSIBLE"<<endl;
    
        }
        return 0;
    }
  • 相关阅读:
    如何完全禁用或卸载Windows 10中的OneDrive
    ASP.NET Web API从注释生成帮助文档
    c#中使用easyUI的DataGrid组件
    第三方分页控件aspnetPager出现问题解决方法
    ActionResult派生类
    Razor引擎的转换数据类型
    ViewData与ViewBag比较
    .net开源后可以查看的源代码
    如何让一个类可以被foreach枚举?
    .NET Framework中Object基类有哪些方法?
  • 原文地址:https://www.cnblogs.com/Ritchie/p/5425399.html
Copyright © 2020-2023  润新知