• #2069:Coin Change(完全背包)


    Problem Description

    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

    Input

    The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

    Output

    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

    Sample Input

    11

    26

    Sample Output

    4

    13

    题意:给你面值有1,5,10,25,50的币种,然后随意输入一个钱的数目,问用这些面值刚好凑成这个钱的方法有多少个(最多100个硬币)

    思路:完全背包

    #include<bits/stdc++.h>
    #define ll long long
    using namespace std;
    const int a[5] = { 1,5,10,25,50 };
    ll dp[255][101];//dp[j][k]:用k个硬币组成j值的个数
    int main()
    {
        int n;
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 1;
        for (int i = 0; i < 5; i++) {
            for (int k = 1; k <= 100; k++) {//k个硬币
                for (int j = a[i]; j <= 250; j++) {
                    dp[j][k] += dp[j - a[i]][k - 1];
                }
            }
        }
        while (cin >> n) {
            int res = 0;
            for (int i = 0; i <= 100; i++) {
                res += dp[n][i];
            }
            cout << res << endl;
        }
        return 0;
    }
    
  • 相关阅读:
    Core Java 5
    pyDay11
    c++第二十一天
    pyDay10
    c++第二十天
    RadioButton控件
    ListBox控件
    Image控件
    FileUpload控件
    DropDownList控件
  • 原文地址:https://www.cnblogs.com/RioTian/p/12804801.html
Copyright © 2020-2023  润新知