• Splitting Pile --AtCoder


    题目描述

    Snuke and Raccoon have a heap of N cards. The i-th card from the top has the integer ai written on it.
    They will share these cards. First, Snuke will take some number of cards from the top of the heap, then Raccoon will take all the remaining cards. Here, both Snuke and Raccoon have to take at least one card.
    Let the sum of the integers on Snuke's cards and Raccoon's cards be x and y, respectively. They would like to minimize |x−y|. Find the minimum possible value of |x−y|.

    Constraints
    2≤N≤2×105
    −109≤ai≤109
    ai is an integer.

    输入

    Input is given from Standard Input in the following format:
    N
    a1 a2 … aN

    输出

    Print the answer.

    样例输入

    6
    1 2 3 4 5 6

    样例输出

    1

    #include <iostream>
    #include <string>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #define range(i,a,b) for(int i=a;i<=b;++i)
    #define LL long long
    #define rerange(i,a,b) for(int i=a;i>=b;--i)
    #define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
    using namespace std;
    const int mxn=2e5+5;
    LL n,num[mxn],sum[mxn],SUM;
    void init(){
        cin>>n;
        range(i,1,n){
            cin>>num[i];
            sum[i]=sum[i-1]+num[i];
            SUM+=num[i];
        }
    }
    void solve(){
        LL MIN=0x7f7f7f7f;
        range(i,1,n-1)if(MIN>abs((sum[i]<<1)-SUM))MIN=abs((sum[i]<<1)-SUM);
        cout<<MIN<<endl;
    }
    int main() {
        init();
        solve();
        return 0;
    }
    View Code
  • 相关阅读:
    数据库
    Python基础
    flask 文件的上传下载和excel操作
    Django 知识点补充
    Django部署时为什么要用 uWSGI与 Nginx? 以及 WSGI,uwsgi等协议
    Memcached 补充
    websocket基本概念
    Tornado 异步非阻塞
    Tornado 自定义session,与一致性哈希 ,基于redis 构建分布式 session框架
    functools 和 itertools
  • 原文地址:https://www.cnblogs.com/Rhythm-/p/9322213.html
Copyright © 2020-2023  润新知