• Sharing Cookies --AtCoder


    题目描述

    Snuke is giving cookies to his three goats.
    He has two cookie tins. One contains A cookies, and the other contains B cookies. He can thus give A cookies, B cookies or A+B cookies to his goats (he cannot open the tins).
    Your task is to determine whether Snuke can give cookies to his three goats so that each of them can have the same number of cookies.

    Constraints
    1≤A,B≤100
    Both A and B are integers.

    输入

    Input is given from Standard Input in the following format:
    A B

    输出

    If it is possible to give cookies so that each of the three goats can have the same number of cookies, print Possible; otherwise, print Impossible.

    样例输入

    4 5

    样例输出

    Possible

    #include <iostream>
    #include <string>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #define range(i,a,b) for(int i=a;i<=b;++i)
    #define rerange(i,a,b) for(int i=a;i>=b;--i)
    #define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
    using namespace std;
    int n,m;
    void init(){
        cin>>n>>m;
    }
    void solve(){
        cout<<((!(n%3)||!(m%3)||!((m+n)%3))?"Possible":"Impossible")<<endl;
    }
    int main() {
        init();
        solve();
        return 0;
    }
    View Code
  • 相关阅读:
    文件操作:Directory,File,FielStream、StreamRead和StreamWriter的使用
    MVC中Excel导入
    T对象序列化后T对象中属性字段不见了?
    Sql游标
    Form表单提交
    AJAX异步删除操作
    数据库表结构导出sql语句
    多线程的使用
    找不到dll原因
    代码优化
  • 原文地址:https://www.cnblogs.com/Rhythm-/p/9322187.html
Copyright © 2020-2023  润新知