• 1010. Radix (25)(未完成)


    Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

    Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

    Input Specification:

    Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
    N1 N2 tag radix
    Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

    Output Specification:

    For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

    Sample Input 1:
    6 110 1 10
    
    Sample Output 1:
    2
    
    Sample Input 2:
    1 ab 1 2
    
    Sample Output 2:
    Impossible
    


    现在是只能拿18分,感觉自己题意理解的有问题,过几天再看看吧,今天实在是看不下去了....




    #include <iostream>
    #include <cmath>
    #include <cstring>
    
    using namespace std;
    
    
    long long int translate(string a,int r){
            long long int a10=0;
            int x;
            int n=a.length();
            int c=0;
            for(int i=n-1;i>=0;i--){
                if(a[i]>96)
                x=a[i]-87;
                else{
                x=a[i]-48;
                }
                a10=a10+x*pow(r,c);
                c++;
             }
             return a10;
    }
    
    int main()
    {
        string a,b;
        long long int a10=0,b10=0;
        int n,r;
        int flag=0;
        cin>>a>>b>>n>>r;
        if(n==1){
            a10=translate(a,r);
            int i;
            if(b.length()==1) i=translate(b,10)+1;
            else i=2;
            for(;i<37;i++){
                if(translate(b,i)==a10){
                    cout<<i<<endl;
                    flag=1;
                    break;
                }
    
            }
          if(flag==0)
            cout<<"Impossible"<<endl;
    
        }
        else if(n==2){
             b10=translate(b,r);
             int i;
             if(a.length()==1) i=translate(a,10)+1;
            else i=2;
             for(;i<37;i++){
                if(translate(a,i)==b10){
                    cout<<i<<endl;
                    flag=1;
                    break;
                }
    
            }
          if(flag==0)
            cout<<"Impossible"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    记事本开发者日记~二
    《梦断代码》读后感①
    记事本开发日记~一
    仓库管理msi系统
    java web + mysql 的增删改查
    第九周动手动脑
    四则运算答题版
    JAVA常用的异常处理情况
    继承和多态中动手动脑
    laravel1
  • 原文地址:https://www.cnblogs.com/Qmelbourne/p/6071427.html
Copyright © 2020-2023  润新知