• 1007. Maximum Subsequence Sum (25)


    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
    Sample Output:
    10 1 4
    



    题本身不难,但是想了好久竟然没有思路... 也是在看了别人的代码后才写出来通过的
    遍历两边,一边遍历一边记录下最大的和以及开始和结束的数字。
    出了一次问题,就是当序列中最大的值是0的时候怎样正确输出 0 0 0



    #include <iostream>
    
    
    using namespace std;
    
    int a[100005];
    
    
    int main()
    {
        int temp,k,start,end1,sum;
        sum=-1;
        cin>>k;
        for(int i=0;i<k;i++){
            cin>>a[i];
        }
        for(int i=0;i<k;i++){
                temp=0;
            for(int j=i;j<k;j++){
                temp=temp+a[j];
                if(temp>sum){
                    sum=temp;
                    start=a[i];
                    end1=a[j];
                }
            }
        }
        if(sum<=-1)
            cout<<0<<" "<<a[0]<<" "<<a[k-1];
        else
            cout<<sum<<" "<<start<<" "<<end1;
    
    
        return 0;
    }
  • 相关阅读:
    nginx公网IP无法访问浏览器
    Internet接入方式
    Adobe Photoshop Lightroom 5.3和序列号
    getopt
    printf
    scanf
    cycling -avoid the vicious cycle
    ACE handle_timeout 事件重入
    Linux查看程序端口占用
    The GNU C Library
  • 原文地址:https://www.cnblogs.com/Qmelbourne/p/6066976.html
Copyright © 2020-2023  润新知