• 最长上升子序列(LIS) Medium2


    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines. 

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one. 

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads. 

    For example, the roads in Figure I are forbidden. 



    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^ 

    InputEach test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file. 
    OutputFor each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
    Sample Input

    2
    1 2
    2 1
    3
    1 2
    2 3
    3 1

    Sample Output

    Case 1:
    My king, at most 1 road can be built.
    
    Case 2:
    My king, at most 2 roads can be built.
    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    
    using namespace std;
    const int N = 500000 + 10;
    struct node{
        int p, r;
    }City[N];
    
    int Q[N];
    
    bool cmp(const node & x, const node & y){
        return x.p < y.p;
    }
    void Solve(int n){
        static int Case = 0;
        sort(City, City + n, cmp);
        memset(Q, 0, sizeof(Q));
        int cur = 0;
        for(int i = 0; i < n; i++){
            if(City[i].r > Q[cur]) Q[++cur] = City[i].r;
            else *upper_bound(Q, Q + cur + 1, City[i].r) = City[i].r;
        }
        printf("Case %d:
    My king, at most %d road%s can be built.
    
    ", ++Case, cur, cur > 1?"s":"");
    }
    int main(){
        int n;
        while(scanf("%d", &n) == 1){
            for(int i = 0; i < n; i++) scanf("%d %d", &City[i].p, &City[i].r);
            Solve( n );
        }
        return 0;
    }
  • 相关阅读:
    [轉][Windows] 已啟用Win7遠端桌面,從家中連回去卻無法連線?
    [轉]False SQL Injection and Advanced Blind SQL Injection
    SQL Injection with INFORMATION_SCHEMA (Mysql)
    Exploiting hard filtered SQL Injections
    Mysql 5 以上有内置库 information_schema,存储着mysql的所有数据库和表结构信息
    12个月内自学完成4年麻省理工学院计算机科学的33门课程的scotthyoung所谓的超速学习理论&方法(费曼技巧)?
    SQLi filter evasion cheat sheet (MySQL)
    [轉]字符形注入
    [轉]渗透测试必备Firefox全套渗透装
    Phpexcel範例
  • 原文地址:https://www.cnblogs.com/Pretty9/p/7406880.html
Copyright © 2020-2023  润新知