• A1027Colors in Mars


    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input Specification:

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output Specification:

    For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

    Sample Input:

    15 43 71

    Sample Output:

    #123456

    思路:

    因为转换成十三进制之后最多有两位,即num/13和num%13,所以边输入边转换输出,又因为10 11 12由ABC表示,所以用一个字符数组做映射。注意,输出中#可以先输出,在循环输入输出之前输出可以AC,只要在输出部分位置正确即可。

     

    #include <iostream>
    using namespace std;
    int main() {
        int num;
        char mp[14] = { "0123456789ABC" };
        cout << "#";
        for (int i = 0; i < 3; i++) {
            cin >> num;
            cout<< mp[num / 13] << mp[num % 13];
        }
        return 0;
    }
    作者:PennyXia
             
    本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。
  • 相关阅读:
    高斯函数 and 对数高斯函数 拟合曲线
    Python3.6、3.7、3.8新特性
    常用限流策略——漏桶与令牌桶介绍
    常用的HTTP服务压测工具介绍
    使用swagger生成接口文档
    validator库参数校验若干实用技巧
    树形结构数据处理
    element-ui 抽屉组件(el-drawer ) 二次封装 增加resize拖曳改变宽度大小
    pm2常用命令
    vue3-- setup中获取数组dom
  • 原文地址:https://www.cnblogs.com/PennyXia/p/12291965.html
Copyright © 2020-2023  润新知