• 博弈 Euclid's Game HDU 1525


    Problem Description
    Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

    25 7
    11 7
    4 7
    4 3
    1 3
    1 0 

    an Stan wins. 

     
    Input
    The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
     
    Output
    For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

     
    Sample Input
    34 12 15 24 0 0
     
    Sample Output
    Stan wins Ollie wins
     
     
    思路:
    分类讨论:
    当A>2*B 的时候 
    先手已经知道 A%B 与 B 的关系
    所以 他可以将其置为 A%B+B 与B 并且让对手被动选择  也就是 让步数+1
     
    code:
    //
    #include<bits/stdc++.h>
    using namespace std;
    int n,m;
    int main()
    {
        while(cin>>n>>m)
        {
            int tot=0;
            if(n==0&&m==0)
            return 0;
            if(n<=m) swap(n,m); 
            if((n%m==0))
            {puts("Stan wins");continue;}
            if((n/m)>=2)
            {puts("Stan wins");continue;}
            while(1)
            {
                tot++;
                n=n%m;
            if(n<=m) swap(n,m); 
            if((n%m==0&&(tot&1)))
            {puts("Ollie wins");break;}
            if((n%m==0&&(!(tot&1))))
            {
                {puts("Stan wins");break;}
            }
            if((n/m)>=2&&(tot&1))
            {puts("Ollie wins");break;}
            if((n/m)>=2&&(!(tot&1)))
            {puts("Stan wins");break;}
            }
            
        }
        
        
        
    }
    刀剑映出了战士的心。而我的心,漆黑且残破
  • 相关阅读:
    带锚点URL同一页面滚动效果的实现
    思路先行
    transliteration -- 2个功能
    html5 section article
    fields('t')
    使用Bootstrap
    JavaScript Switch
    菜单
    写一个博客页面
    自动适应
  • 原文地址:https://www.cnblogs.com/OIEREDSION/p/11308411.html
Copyright © 2020-2023  润新知