• POJ 2631 Roads in the North (树的直径裸题)


    Description
    Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
    Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.
    The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.

    Input
    Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

    Output
    You are to output a single integer: the road distance between the two most remote villages in the area.

    Sample Input
    5 1 6
    1 4 5
    6 3 9
    2 6 8
    6 1 7

    Sample Output
    22
    题意:求树上最长的两个点之间的距离
    思路:这里有一个结论,在图中,要找到距离最远的两点,先随便从一个点入手BFS,找到距离这个点最远的点,在从这个点BFS找到距离这点最远的点,这两点之间的距离就是这棵树的直径。所以直接进行BFS搜索就行了。
    AC code:

    #include <iostream>
    #include <cstring>
    #include <queue>
    #include <vector>
    
    const int maxn =100020;
    
    using namespace std;
    
    int dis[maxn],ans;
    bool vis[maxn];
    vector<pair<int,int> >V[maxn];
    
    int bfs(int x){
        memset (dis ,0 ,sizeof(dis) );
        memset (vis ,0 ,sizeof(vis) );
        queue <int >Q;
        Q.push(x); vis[x]=1;
        int point =0;
        while (!Q.empty()){
            int F = Q.front();
            Q.pop();
            if(dis[F]>ans){
                ans = dis[F];
                point = F;
            }
            pair <int,int>t;
            for (int i=0;i<V[F].size();i ++){
                t=V[F][i];
                if(vis [t.first]==0){
                vis [t.first]=1;
                dis [t.first]= dis[F]+t.second ;
                Q.push(t.first );
                }
            }
        }
        return point;
    }
    
    int main (){
        int x,y,z;
        while (cin>>x>>y>>z){
            V[x].push_back( make_pair(y,z));
            V[y].push_back( make_pair(x,z));
        }
        ans =0;
        int point =bfs(1);
        ans =0;
        bfs(point);
        cout <<ans<<endl ;
        return 0;
    }
  • 相关阅读:
    【css】ie6下使用css sprite 滤镜做透明图片
    【css】float:left不撑满容器与opacity将子元素透明demo
    mysql日期时间操作
    html5入门信息
    一个简单的文件递归例子
    oracle事务特性详解
    如何安装Oracle Database 11g数据库
    使用DOM进行xml文档的crud(增删改查)操作<操作详解>
    CSS中的盒子模型详解
    IP V4地址分类
  • 原文地址:https://www.cnblogs.com/Nlifea/p/11745969.html
Copyright © 2020-2023  润新知