• Problem F: Exponentiation大数求幂


    Description
    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999) and n is an integer such that $0 < n le 25$.

    Input
    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

    Output
    The output will consist of one line for each line of input giving the exact value of Rn. Leading zeros and insignificant trailing zeros should be suppressed in the output.

    Sample Input
    95.123 12
    0.4321 20
    5.1234 15
    6.7592 9
    98.999 10
    1.0100 12
    Sample Output
    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401
    43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201
    思路:注意当输入1.10000时我是先变成1.1处理

    #include<stdio.h>
    #include<iostream>
    using namespace std;
    #include<string.h>
    void chengfa(char a[],char b[])
    {
        int sum[1001];
        int lena=strlen(a)-1;
        int lenb=strlen(b)-1;
        int t1=lena;
        int t;
        memset(sum ,0,sizeof(sum));
        for(int i=lena;i>=0;i--)
            for(int j=lenb,t=1000-(t1-i);j>=0;j--)
                sum[t--]+=(a[i]-'0')*(b[j]-'0');
        for(int k=1000;k>=1;k--)
         {
            sum[k-1]+=sum[k]/10;
            sum[k]=sum[k]%10;
         }
         int start=0;
         while(start<=1000&&!sum[start])
            start++;
            memset(a,0,sizeof(a));
            int t2=0;
         for(int k=start;k<=1000;k++)
            a[t2++]=sum[k]+'0';
            a[t2]='';
     
    }
    int main()
    {
        char a[1001],b[1001];
        char a1[1001],a2[1003];
        int n;
        memset(b,0,sizeof(b));
        while(cin>>a>>n)
        {
            int k6;
            int len6=strlen(a);
            for(k6=len6-1;k6>=0;k6--)
                if(a[k6]!='0')
               {
                a[k6+1]='';
                break;
               }
            int len1=strlen(a);
            int k;
            for(int i=0;i<len1;i++)
                if(a[i]=='.')
            {    k=(len1-1)-i;
                int j;
                for(j=i;j<len1;j++)
                    a[j]=a[j+1];
                    a[j]='';
                     len1--;
                     break;
     
            }
              int num=k*n;
            strcpy(b,a);
                n=n-1;
                while(n--)
               chengfa(a,b);
               int len2=strlen(a);
               int count1=0;
             int k1,k2,k3,k4;
               int lena=strlen(a)-count1;
            if(num<lena)                           没有前导0,即第一个是数字是大于0
               {
                   for(k1=0;k1<lena-num;k1++)
                    cout<<a[k1];
                     cout<<'.';
                     for(k2=k1;k2<lena;k2++)
                        cout<<a[k2];
                        cout<<endl;
               }
               else                                //有前导0
               {
     
                   printf(".");
                   for(k3=num-lena;k3>0;k3--)
                        printf("0");
                   cout<<a;
                   cout<<endl;
               }
        }
        return 0;
    }
  • 相关阅读:
    windows server 2008 R2下如何快速开启远程桌面、1433、telnet
    利用Lambda获取类中属性名称
    EntityFramework之迁移操作(五)
    EntityFramework之多对多关系(四)
    EntityFramework之一对多关系(三)
    EntityFramework之一对一关系(二)
    EntityFramework之创建数据库及基本操作(一)
    Javascript短路表达式
    Javascript中call、apply函数浅析
    Javascript"怪异"现象
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4236899.html
Copyright © 2020-2023  润新知