• Problem G: Keywords Search


    Problem G: Keywords Search
    Time Limit: 1 Sec Memory Limit: 128 MB
    Submit: 10 Solved: 6
    [Submit][Status][Web Board] [Edit] [TestData]
    Description
    n the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
    Wiskey also wants to bring this feature to his image retrieval system.
    Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
    To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

    Input
    First line will contain one integer means how many cases will follow by.
    Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
    Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
    The last line is the description, and the length will be not longer than 1000000.

    Output
    Print how many keywords are contained in the description.

    Sample Input
    1
    5
    she
    he
    say
    shr
    her
    yasherhs
    Sample Output
    3

    #include<iostream>
    #include<stdio.h>
    #include<string>
    #include<string.h>
    using namespace std;
    char b[1000000];//存放句子
    int main()
    {
        int n,gjc,i,j,len,lena,k,ji,count;
        string a[10000];
    while(scanf("%d",&n)!=EOF)  //总的测试的个数
    {
        while(n--)
        {
            cin>>gjc;//关键词的个数
        for(i=0;i<gjc;i++)
        {
            cin>>a[i];
        }
        getchar();
        gets(b);
        len=strlen(b);
        count=0;
        for(i=0;i<gjc;i++)
        {
            lena=a[i].size();
            for(j=0;j<len;j++)
            {
                ji=0;   
                for(k=0;k<lena;k++)
                {
                    if(b[j]!=a[i][k])
                    {
                        j=j-ji;
                        break;
                    }
                    else
                    {
                        ji++;
                        j++;
                    }
                }
                if(ji==lena)
                {
                    count++;
                    j=j-lena;
                }
            }
        }
        cout<<count<<endl;
    }
    }
        return 0;
    }
  • 相关阅读:
    Block的强强引用问题(循环引用)
    自己封装的下载方法
    MJRefresh上拉刷新下拉加载
    JavaScript 模块的循环加载
    webpack使用require注意事项
    console.log高级用法
    path.resolve()和path.join()的区别
    深入理解react
    react children技巧总结
    揭秘css
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4236893.html
Copyright © 2020-2023  润新知