• USACO hamming


    考试周终于过去了一半,可以继续写USACO了。

    先来看一下题目吧。

    Hamming Codes
    Rob Kolstad

    Given N, B, and D: Find a set of N codewords (1 <= N <= 64), each of length B bits (1 <= B <= 8), such that each of the codewords is at least Hamming distance of D (1 <= D <= 7) away from each of the other codewords. The Hamming distance between a pair of codewords is the number of binary bits that differ in their binary notation. Consider the two codewords 0x554 and 0x234 and their differences (0x554 means the hexadecimal number with hex digits 5, 5, and 4):

            0x554 = 0101 0101 0100
            0x234 = 0010 0011 0100
    Bit differences: xxx  xx
    

    Since five bits were different, the Hamming distance is 5.

    PROGRAM NAME: hamming

    INPUT FORMAT

    N, B, D on a single line

    SAMPLE INPUT (file hamming.in)

    16 7 3
    

    OUTPUT FORMAT

    N codewords, sorted, in decimal, ten per line. In the case of multiple solutions, your program should output the solution which, if interpreted as a base 2^B integer, would have the least value.

    SAMPLE OUTPUT (file hamming.out)

    0 7 25 30 42 45 51 52 75 76
    82 85 97 102 120 127
    

     这条题目不难,由于数据量很小,因此使用的方法是直接遍历。

    /**
    ID: njuwz151
    TASK: hamming
    LANG: C++
    */
    #include <iostream>
    #include <cstdio>
    
    using namespace std;
    
    const int maxn = 9;
    
    int count(int a, int b);
    
    int main() {
        freopen("hamming.in", "r", stdin);
        freopen("hamming.out", "w", stdout);
        
        int n, b, d;
        cin >> n >> b >> d;
        
        int result[1 << maxn];
        result[0] = 0;
        int n_ptr = 1;
        for(int i = 1; i < (1 << b); i++) {
            if(n_ptr > n) {
                break;
            }
            bool can_add = true;
            for(int j = 0; j < n_ptr; j++) {
                if(count(i, result[j]) < d) {
                    can_add = false;
                    break;
                }
            }
            if(can_add) {
                result[n_ptr] = i;
                n_ptr++; 
            }
        }
        for(int i = 0; i < n - 1; i++) {
            cout << result[i];
            if((i + 1) % 10) {
                cout << " ";
            } else {
                cout << endl;
            }
        }
        cout << result[n - 1] << endl;
    } 
    
    int count(int a, int b) {
        int result = 0;
        for(int i = 0; i < maxn; i++) {
            if(((a>>i) & 1) != ((b>>i) & 1)) {
                result++;
            }
        }
        return result;
    }
  • 相关阅读:
    Elastic的should + bool 多字段完全匹配或查找
    MySQL慢日志
    Elastic的IN查找
    Elastic的字符串查找
    JavaScript获取当前时间戳
    原码, 反码, 补码学习笔记
    PHP渲染压缩HTML
    JavaScript的深拷贝
    JavaScript的变量的let const var的区别
    关于一个值该不该default null的判定
  • 原文地址:https://www.cnblogs.com/NJUWZ/p/7093126.html
Copyright © 2020-2023  润新知