• USACO Healthy Holsteins


    首先看题目:

    Healthy Holsteins
    Burch & Kolstad

    Farmer John prides himself on having the healthiest dairy cows in the world. He knows the vitamin content for one scoop of each feed type and the minimum daily vitamin requirement for the cows. Help Farmer John feed his cows so they stay healthy while minimizing the number of scoops that a cow is fed.

    Given the daily requirements of each kind of vitamin that a cow needs, identify the smallest combination of scoops of feed a cow can be fed in order to meet at least the minimum vitamin requirements.

    Vitamins are measured in integer units. Cows can be fed at most one scoop of any feed type. It is guaranteed that a solution exists for all contest input data.

    PROGRAM NAME: holstein

    INPUT FORMAT

    Line 1: integer V (1 <= V <= 25), the number of types of vitamins
    Line 2: V integers (1 <= each one <= 1000), the minimum requirement for each of the V vitamins that a cow requires each day
    Line 3: integer G (1 <= G <= 15), the number of types of feeds available
    Lines 4..G+3: V integers (0 <= each one <= 1000), the amount of each vitamin that one scoop of this feed contains. The first line of these G lines describes feed #1; the second line describes feed #2; and so on.

    SAMPLE INPUT (file holstein.in)

    4
    100 200 300 400
    3
    50   50  50  50
    200 300 200 300
    900 150 389 399
    

    OUTPUT FORMAT

    The output is a single line of output that contains:

    • the minimum number of scoops a cow must eat, followed by:
    • a SORTED list (from smallest to largest) of the feed types the cow is given

    If more than one set of feedtypes yield a minimum of scoops, choose the set with the smallest feedtype numbers.

    SAMPLE OUTPUT (file holstein.out)

    2 1 3

    这题的思路是这样的,看到数据量很小,首先枚举所有的情况,然后一一判断是否合法。
    /**
    ID: njuwz151
    TASK: holstein
    LANG: C++
    */
    #include <iostream>
    #include <cstdio>
    #include <bitset>
    #include <cstring>
    
    using namespace std;
    
    const int max_v = 30;
    const int max_g = 20;
    
    int main() {
        freopen("holstein.in", "r", stdin);
        freopen("holstein.out", "w", stdout);
        
        bitset<max_g> minbit(0);
        int min_count = max_g + 1;
        int feed[max_v];
        
        int v;
        int req[max_v];
        cin >> v;
        for(int i = 0; i < v; i++) {
            cin >> req[i];
        }
        int g;
        int food[max_g][max_v];
        cin >> g;
        for(int i = 0; i < g; i++) {
            for(int j = 0; j < v; j++) {
                cin >> food[i][j];
            }
        }
        
        for(int i = 0; i < (1 << g); i++) {
            bitset<max_g> bit(i);
            int to_feed[max_v];
            memset(to_feed, 0, sizeof to_feed);
            for(int j = 0; j < g; j++) {
                if(bit[j]) {
                     for(int k = 0; k < v; k++) {
                         to_feed[k] += food[j][k];
                     }
                }
            }
            
            bool valid = true;
            for(int j = 0; j < v; j++) {
                if(to_feed[j] < req[j]) {
                    valid = false;
                    break;
                }
            }
            if(valid && int(bit.count()) < min_count) {
                minbit = bit;
                min_count = minbit.count();
                continue;
            }
            
            if(valid && int(bit.count()) == min_count) {
                bool ok = true;
                for(int i = 0; i < g; i++) {
                    if(bit[i] > minbit[i]) {
                        break;
                    } else if(bit[i] < minbit[i]) {
                        ok = false;
                        break;
                    }
                }
                if(ok) {
                    minbit = bit;
                    min_count = minbit.count();    
                }
            }
         }
         
         cout << min_count;
         for(int i = 0; i < g; i++) {
             if(minbit[i]) {
                 cout << " " << i+1;
             }
        }
        cout << endl;
    }
  • 相关阅读:
    Python 中lambda 简单介绍
    关于python中带下划线的变量和函数 的意义
    Python 类的方法,下划线有什么不同?
    Python中用format函数格式化字符串的用法(2.7版本讲解哦!)
    如何理解 Python 中的__init__
    Python引用多个模块,调用模块中的函数时,要注意的地方
    Python tips: 什么是*args和**kwargs?
    如何简单地理解Python中的if __name__ == '__main__'
    NLP点滴——文本相似度
    马里奥AI实现方式探索 ——神经网络+增强学习
  • 原文地址:https://www.cnblogs.com/NJUWZ/p/7061906.html
Copyright © 2020-2023  润新知