• Hdoj 1548.A strange lift 题解


    Problem Description

    There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
    Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

    Input

    The input consists of several test cases.,Each test case contains two lines.
    The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
    A single 0 indicate the end of the input.

    Output

    For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

    Sample Input

    5 1 5
    3 3 1 2 5
    0
    

    Sample Output

    3
    

    思路

    状态的转移方式只有2种,要么上,要么下,至于每次移动的距离则是(k[i]),根据这个来bfs就对了

    代码

    #include<bits/stdc++.h>
    using namespace std;
    struct node
    {
    	int pos;
    	int step;
    }st;
    int n,a,b;
    int k[201];
    bool vis[200010];
    
    bool judge(int x)
    {
    	if(vis[x] || x<1 || x>n)
    		return false;
    	return true;
    }
    int bfs(int a)
    {
    	queue<node> q;
    	st.pos = a;
    	st.step = 0;
    	q.push(st);
    	node next,now;
    	memset(vis,false,sizeof(vis));
    	vis[st.pos] = true;
    	while(!q.empty())
    	{
    		now = q.front();
    		q.pop();
    		if(now.pos == b) return now.step;
    		for(int i=0;i<2;i++)
    		{
    			if(i==0)
    				next.pos = now.pos + k[now.pos];
    			else
    				next.pos = now.pos - k[now.pos]; 
    			next.step = now.step + 1; 
    			if(judge(next.pos))
    			{
    				q.push(next);
    				vis[next.pos] = true;
    			}
    		}
    	}
    	return -1;
    }
    		
    int main()
    {
    	while(cin>>n)
    	{
    		if(n==0) break;
    		cin >> a >> b;
    		for(int i=1;i<=n;i++)
    			cin >> k[i];
    		int ans = bfs(a);
    		cout << ans << endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    丰富eclipse注解的内容
    ThreadLocal总结
    算法+结构?设计模式?
    面试需要准备内容
    HIbernate-0.8版本源码翻看
    2019第一篇博文
    随笔
    Expert one on one 读书笔记之容器
    Expert one on one development without ejb读书笔记
    Mysql索引部分学习关于多列索引的部分
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/9903196.html
Copyright © 2020-2023  润新知