• PAT(Advanced Level)1055.The World's Richest


    Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

    Output Specification:

    For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

    Name Age Net_Worth
    

    The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

    Sample Input:
    12 4
    Zoe_Bill 35 2333
    Bob_Volk 24 5888
    Anny_Cin 95 999999
    Williams 30 -22
    Cindy 76 76000
    Alice 18 88888
    Joe_Mike 32 3222
    Michael 5 300000
    Rosemary 40 5888
    Dobby 24 5888
    Billy 24 5888
    Nobody 5 0
    4 15 45
    4 30 35
    4 5 95
    1 45 50
    
    Sample Output:
    Case #1:
    Alice 18 88888
    Billy 24 5888
    Bob_Volk 24 5888
    Dobby 24 5888
    Case #2:
    Joe_Mike 32 3222
    Zoe_Bill 35 2333
    Williams 30 -22
    Case #3:
    Anny_Cin 95 999999
    Michael 5 300000
    Alice 18 88888
    Cindy 76 76000
    Case #4:
    None
    
    思路
    • 读进来结构体数组之后进行题目要求的排序,对于题目的每一个query遍历一遍,找满足年龄条件的,对输出进行计数,等于M之后就退出
    代码
    #include<bits/stdc++.h>
    using namespace std;
    struct billionaire
    {
    	string name;
    	int age, worth;
    }a[100010];
    
    bool cmp(billionaire a, billionaire b)
    {
    	if(a.worth != b.worth)
    		return a.worth > b.worth;
    	else if(a.age != b.age)
    		return a.age < b.age;
    	else
    		return a.name < b.name;
    }
    
    int main()
    {
    	int n, k;
    	cin >> n >> k;
    	for(int i=0;i<n;i++)
    	{
    		cin >> a[i].name >> a[i].age >> a[i].worth;
    	}
    	sort(a, a+n, cmp);
    	int m, l, r;
    	for(int i=0;i<k;i++)
    	{
    		cin >> m >> l >> r;
    		cout << "Case #" << i+1 << ":" << endl;
    		int pos = 0;
    		int tmp = m;    //暂时存储m的值
    		while(pos != n)   //遍历一遍排序好的数据,逐个判断年龄是否满足条件
    		{
    			if(a[pos].age >= l && a[pos].age <= r)  //满足年龄条件
    			{
    				m--;
    				cout << a[pos].name << " " << a[pos].age << " " << a[pos].worth << endl;
    			}
    			if(m == 0)  break;
    			pos++;
    		}
    		if(m == tmp)   cout << "None" << endl; //这里不能用m!=0,不然会报错,猜测可能是有找到部分没完全找到的情况下多输出了None
    	}
    	return 0;
    }
    
    
    
    引用

    https://pintia.cn/problem-sets/994805342720868352/problems/994805421066272768

  • 相关阅读:
    jsp登录显示
    flask 分页
    module pip has no attribute main
    html active属性
    Centos7配置
    python爬虫笔记----4.Selenium库(自动化库)
    python爬虫笔记
    python报错记录
    mybatis逆向文件
    python简单验证码
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/11842755.html
Copyright © 2020-2023  润新知