• Hdoj 1856.More is better 题解


    Problem Description

    Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

    Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

    Input

    The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

    Output

    The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

    Sample Input

    4
    1 2
    3 4
    5 6
    1 6
    4
    1 2
    3 4
    5 6
    7 8
    

    Sample Output

    4
    2
    
    
    
    Hint
    A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
    then A and C are also friends(indirect).
    
     In the first sample {1,2,5,6} is the result.
    In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
      
    

    Author

    lxlcrystal@TJU

    Source

    HDU 2007 Programming Contest - Final


    思路

    裸并查集,只要找到所有分出来的集合当中元素最多的集合就行了,为此需要一个数组来记录个数,详见代码

    代码

    #include<bits/stdc++.h>
    using namespace std;
    int father[10000010];
    int num[10000010];
    int MaxValue;
    void init(int n)
    {
        for(int i=1;i<=n;i++)
    	{
    		father[i]=i;
    		num[i] = 1;
    	}
    }
    int find(int x)
    {
        if(father[x]!=x) father[x] = find(father[x]);
        return father[x];
    }
    void join(int a,int b)
    {
        int t1=find(a);
        int t2=find(b);
        if(t1!=t2)
    	{
    		father[t1]=t2;
    		num[t2] += num[t1];
    		MaxValue = max(num[t2],MaxValue);
    	}
    }
    int main()
    {
    	int n;
    	while(scanf("%d",&n)!=EOF)
    	{
    		if(n==0)
    		{ 
    			cout << 1 << endl;
    			continue;
    		}
    		init(10000000);
    		MaxValue = -1;
    		for(int i=1;i<=n;i++)
    		{
    			int a,b;
    			scanf("%d%d",&a,&b);
    			if(find(a) != find(b)) join(a,b);
    		}
    		cout << MaxValue << endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    python-打包程序
    python-记log
    Git-分支
    跨线程调用控件之MethodInvoker
    c# Invoke和BeginInvoke 区别
    winform 开发之Control.InvokeRequired
    C#三种定时器的实现
    winform窗口打开后文本框的默认焦点设置
    C#在Winform中改变Textbox高度三种方法
    Json.net/Newtonsoft 3.0 新特性JObject/Linq to Json
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/10048561.html
Copyright © 2020-2023  润新知