• Hdoj 1879.继续畅通工程 题解


    Problem Description

    省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。

    Input

    测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

    当N为0时输入结束。

    Output

    每个测试用例的输出占一行,输出全省畅通需要的最低成本。

    Sample Input

    3
    1 2 1 0
    1 3 2 0
    2 3 4 0
    3
    1 2 1 0
    1 3 2 0
    2 3 4 1
    3
    1 2 1 0
    1 3 2 1
    2 3 4 1
    0
    

    Sample Output

    3
    1
    0
    

    Author

    ZJU

    Source

    浙大计算机研究生复试上机考试-2008年


    思路

    路有修通和没有修通的状态,显然只有没修通的才要考虑成本,把已经修通的路的权值赋值为1,就可以达到这个效果,然后依旧是Kruskal算法

    代码

    #include<bits/stdc++.h>
    using namespace std;
    int father[110];
    struct Graph
    {
    	int u;//起点
    	int v;//终点
    	int dis;//距离
    }maps[10010];
    
    void init(int n)
    {
        for(int i=1;i<=n;i++) father[i]=i;
    }
    int find(int x)
    {
        while(father[x]!=x) x=father[x];
        return x;
    }
    void join(int a,int b)
    {
        int t1=find(a);
        int t2=find(b);
        if(t1!=t2) father[t1]=t2;
    }
    int main()
    {
    	int n;
    	while(scanf("%d",&n))
    	{
    		if(n==0) break; 
    		int num = n*(n-1)/2;
    		int edgeNum = 0;
    		int flag;
    		for(int i=1;i<=num;i++)
    		{
    			scanf("%d%d%d",&maps[i].u,&maps[i].v,&maps[i].dis);
    			scanf("%d",&flag);
    			if(flag==1)
    				maps[i].dis = 0;//路已经修通
    		} 
    		init(n); 
    		int sum = 0 ;
    		sort(maps+1,maps+1+num,[](Graph x,Graph y)->bool{ return x.dis < y.dis;});
    		for(int i=1;i<=num;i++)
    		{
    			if(find(maps[i].u) != find(maps[i].v))
    			{
    				join(maps[i].u,maps[i].v);
    				sum += maps[i].dis;
    			}
    		}
    		cout << sum << endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    触发器
    突然的感慨
    最近接手一个asp老项目,运行了4,5年了
    导出sql语句相关问题
    PHP入门速成
    统一项目时间格式(DateTime.ParseExact使用)
    想法太多了就是三脚猫。
    个人习惯培养计划(转):以此为诫,努力提高自身素质。
    excel处理函数打包
    ASP.Net MVC探索之路 增加字符串长度范围校验Attribute
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/10042147.html
Copyright © 2020-2023  润新知