• HDU1072 Nightmare BFS


    Nightmare

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2853    Accepted Submission(s): 1423


    Problem Description

    Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

    Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

    Here are some rules:
    1. We can assume the labyrinth is a 2 array.
    2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
    3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
    4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
    5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
    6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
     

    Input

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius' start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius' target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
     

    Output

    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
     

    Sample Input
    3
    3 3
    2 1 1
    1 1 0
    1 1 3
    4 8
    2 1 1 0 1 1 1 0
    1 0 4 1 1 0 4 1
    1 0 0 0 0 0 0 1
    1 1 1 4 1 1 1 3
    5 8
    1 2 1 1 1 1 1 4
    1 0 0 0 1 0 0 1
    1 4 1 0 1 1 0 1
    1 0 0 0 0 3 0 1
    1 1 4 1 1 1 1 1
     

    Sample Output
    4
    -1
    13
       
      该题较一般的迷宫搜索又有了变化,这里主人公身上被绑了一个炸弹,如果在走的途中没有得到补给就会挂掉,所以在搜索时除了记录步数外还需要记录剩余的时间,即生命值,对于每个点而言不是访问后便舍弃,而是一直处于可更新状态,只要下一次到达这点的生命值比该次的生命值高即可,由于BFS始终会保持逐步推进,所以我并不担心这样会产生坏解,因为如果前面的点在稍的生命值下能够走到出口也是会先出队列的,在写的时候还是加了优先队列,(不用也能A掉这道题目)其实这样算出来会是步数最少的情况下以最大生命值到达终点的解,由于本题无此要求,所以这里不用亦可。
      代码如下:
    #include <cstdlib>
    #include <cstring>
    #include <cstdio>
    #include <queue>
    using namespace std;
    
    char map[15][15], hash[15][15];
    
    int dir[4][2]= { 1, 0, -1, 0, 0, 1, 0, -1 };
    
    struct Node
    {
    	int x, y, step, life;
    	bool operator < ( const Node &t ) const
    	{
    	    if( step!= t.step )
    	    {
    	        return t.step< step;
    	    }
    	    else
    	    {
    	        return life< t.life;
    	    }
    	}
    }info;
    
    void gchar( char &c )
    {
    	while( c= getchar(), c< '0'|| c> '9' ) ;
    }
    
    
    bool BFS( int sx, int sy, int &ans )
    {
    	memset( hash, 0, sizeof( hash ) );
    	info.x= sx, info.y= sy, info.step= 0, info.life= 6;
    	hash[sx][sy]= 6;
    	priority_queue< Node >q;
    	q.push( info );
    	while( !q.empty() )
    	{
    		Node pos= q.top();
    		q.pop();
    		if( map[pos.x][pos.y]== '3' )
    		{
    			ans= pos.step;
    			return true;
    		}
    		for( int i= 0; i< 4; ++i )
    		{
    			int x= pos.x+ dir[i][0], y= pos.y+ dir[i][1], step= pos.step+ 1, life= pos.life- 1;
    			if( map[x][y]!= 0 )
    			{
    				if( life> hash[x][y] )
    				{
    					if( map[x][y]== '1'|| map[x][y]== '3' )
    					{
    						info.x= x, info.y= y, info.step= step, info.life= life;
    						q.push( info );
    						hash[x][y]= life;
    					}
    					if( map[x][y]== '4' )
    					{
    						info.x= x, info.y= y, info.step= step, info.life= 6;
    						q.push( info );
    						hash[x][y]= 6;
    					}
    				}
    			}
    		}
    	}
    	return false;
    }
    
    int main()
    {
    	int T;
    	scanf( "%d", &T );
    	while( T-- )
    	{
    		int N, M, flag= 0, ans, sx, sy;
    		scanf( "%d %d", &N, &M );
    		memset( map, 0, sizeof( map ) );
    		for( int i= 1; i<= N; ++i )
    		{
    			for( int j= 1; j<= M; ++j )
    			{
    				gchar( map[i][j] );
    				if( !flag&& map[i][j]== '2' )
    				{
    					sx= i, sy= j;
    					flag= 1;
    				}
    			}
    		}
    		if( BFS( sx, sy, ans ) )
    		{
    			printf( "%d\n", ans );
    		}
    		else
    		{
    			puts( "-1" );
    		}
    	}
    }
    

  • 相关阅读:
    什么是Sentinel?它能做什么
    【转】Sentinel 快速入门
    Cause: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure 解决
    【转】接口幂等性设计
    springboot1.5版本
    测试左移实践和总结
    测试左移和右移
    Linux-018-Centos Shell 判断软件是否已经安装
    PySe-018-Requests 解决响应乱码
    PySe-017-Requests 访问 HTTPS 网站安全告警信息(TLS Warnings / InsecureRequestWarning)处理
  • 原文地址:https://www.cnblogs.com/Lyush/p/2132372.html
Copyright © 2020-2023  润新知