• HDU1004 Let the Balloon Rise STL map


    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 30799    Accepted Submission(s): 10110


    Problem Description

    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     

    Input

    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     

    Output

    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     

    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     

    Sample Output
    red
    pink
     
      直接使用map来映射,方便至极。
    #include <iostream>
    #include <string>
    #include <map>
    using namespace std;
    
    int main(  )
    {
    	int N;
    	while( cin>> N, N )
    	{
    		string temp;
    		map< string, int > mp;
    		map< string, int >:: iterator it;
    		for( int i= 1; i<= N; ++i )
    		{
    			cin>> temp;
    			mp[temp]++;
    		}	
    		int max= -1;	
    		for( it= mp.begin(); it!= mp.end(); ++it )
    		{
    			if( max< it->second )
    			{
    				max= it->second;
    				temp= it->first;
    			}
    		}
    		cout<< temp<< endl;
    	}
    }
    

  • 相关阅读:
    vmware中三种网络连接方式
    【史上最全面经】各岗位汇总目录
    史上最全2019届秋招备战攻略
    程序员常用软件
    经典大数据面试题
    春招实习终于结束啦
    Java程序员自我介绍
    java一些面试题
    收割大厂offer需要具备的条件
    triangular distribution
  • 原文地址:https://www.cnblogs.com/Lyush/p/2122762.html
Copyright © 2020-2023  润新知