• HDU-1114 Piggy-Bank


    时间限制 1000ms 空间限制 32768KB

    题目:

    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

    输入:

    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

    输出:

    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

    样例输入:

    3

    10 110

    2

    1 1

    30 50

    10 110

    2

    1 1

    50 30

    1 6

    2

    10 3

    20 4

    样例输出:

    The minimum amount of money in the piggy-bank is 60.

    The minimum amount of money in the piggy-bank is 100.

    This is impossible.

    题意:

    有一个存钱罐,存钱罐里面装着不同种类的钱,每一种钱都有它的面值和它的重量。给你单独存钱罐的质量以及装了钱的存钱罐的质量,然后给你几种钱的面值和他们各自得重量,问存钱罐里得钱最少有多少,如果给出的条件是不可能的,要输出题目相应得输出。

    思路:

    完全背包模板题,按照完全背包做就能AC。

    AC代码:

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<map>
    #include<set>
    #include<queue>
    #include<algorithm>
    #include<stack>
    #define INF 0x3f3f3f3f
    #define ONF 0xc0c0c0c0
    typedef long long LL;
    using namespace std;
    int main()
    {
        int T,m,k,n,s,val[505],v[505];
        LL dp[10005];
        cin>>T;
        while(T--)
        {
            memset(dp,INF,sizeof(dp));
            dp[0]=0;
            cin>>m>>k>>n;
            int s=k-m;
            for(int i=1;i<=n;i++)
            {
                cin>>val[i]>>v[i];
            }
            for(int i=1;i<=n;i++)
                for(int j=v[i];j<=s;j++)
                dp[j]=min(dp[j],dp[j-v[i]]+val[i]);
            if(dp[s]>1e8)
                cout<<"This is impossible."<<endl;
            else
            cout<<"The minimum amount of money in the piggy-bank is "<<dp[s]<<"."<<endl;
        }
    }
  • 相关阅读:
    函数模板
    c#使用多线程的几种方式示例详解
    C#中数组、ArrayList和List三者的区别
    c# Thread类
    IEnumerable和IEnumerator 详解
    C#执行CMD命令并接收返回结果的实现方法
    C# Process.Start()方法详解
    C#Json转Xml格式数据的方法
    sql存储过程
    SQL存储过程基础
  • 原文地址:https://www.cnblogs.com/Leozi/p/13281237.html
Copyright © 2020-2023  润新知