• PAT (Basic Level) Practice (中文) 1081 检查密码 (15分)


    1.题目

    本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字

    输入格式:

    输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

    输出格式:

    对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

    • 如果密码合法,输出Your password is wan mei.
    • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
    • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
    • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
    • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

    输入样例:

    5
    123s
    zheshi.wodepw
    1234.5678
    WanMei23333
    pass*word.6
    

    输出样例:

    Your password is tai duan le.
    Your password needs shu zi.
    Your password needs zi mu.
    Your password is wan mei.
    Your password is tai luan le.

     2.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    using namespace std;
    int main()
    {
    	int n;
    	string temp;
    	cin >> n;
    	getchar();
    	for (int i = 0; i < n; i++)
    	{
    		getline(cin, temp);
    		if (temp.length() < 6) { cout << "Your password is tai duan le." << endl; continue; }
    		int count = 0; bool  num = false, alpha = false;
    		for (int j = 0; j < temp.length(); j++)
    		{
    			if (temp[j] >= '0'&&temp[j] <= '9' || temp[j] >= 'A'&&temp[j] <= 'Z' || temp[j] >= 'a'&&temp[j] <= 'z' || temp[j] == '.')
    				count++;
    			if (temp[j] >= '0'&&temp[j] <= '9')num = true;
    			if (temp[j] >= 'A'&&temp[j] <= 'Z' || temp[j] >= 'a'&&temp[j] <= 'z')alpha = true;
    		}
    		if (count != temp.length()) { cout << "Your password is tai luan le." << endl; continue; }
    		if(!num&&alpha) { cout << "Your password needs shu zi." << endl; continue; }
    		if (num&&!alpha) { cout << "Your password needs zi mu." << endl; continue; }
    		cout << "Your password is wan mei." << endl;
    	}
    
    }
  • 相关阅读:
    Redis 之 数据持久化、主从复制、哨兵、集群
    Linux 之 MySQL(mariadb) 主从复制
    python 面试题
    Linux 之 nginx相关
    Linux 之redis 的安装及使用
    Linux 之 安装虚拟环境virtualenvwrapper
    Vue使用Element-ui走马灯功能动态改变图片和容器大小
    文本信息抽取的方法
    python3 将文本用utf-8编码方式写入txt文件
    一个比celery更简单的python异步模块rq
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788909.html
Copyright © 2020-2023  润新知