• PAT (Basic Level) Practice (中文) 1093 字符串A+B (20分)


    1.题目

    给定两个字符串 A 和 B,本题要求你输出 A+B,即两个字符串的并集。要求先输出 A,再输出 B,但重复的字符必须被剔除

    输入格式:

    输入在两行中分别给出 A 和 B,均为长度不超过 10​6​​的、由可见 ASCII 字符 (即码值为32~126)和空格组成的、由回车标识结束的非空字符串。

    输出格式:

    在一行中输出题面要求的 A 和 B 的和。

    输入样例:

    This is a sample test
    to show you_How it works
    

    输出样例:

    This ampletowyu_Hrk

    2.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    using namespace std;
    int list[127];
    int main()
    {
    	string a, b;
    	getline(cin, a);
    	getline(cin, b);
    	for (int i = 0; i < a.length(); i++)
    	{
    		if (list[a[i]] == 0) { cout << a[i]; list[a[i]]++; }
    	}
    	for (int i = 0; i < b.length(); i++)
    	{
    		if (list[b[i]] == 0) { cout << b[i]; list[b[i]]++; }
    	}
    
    }
  • 相关阅读:
    新概念4-38
    新概念4-37
    新概念4-36
    新概念4-35
    国史通鉴-03 天下为私 04
    新概念4-34
    西门子 框架断路器 及其他中低压配电设备资料查询
    OPC UA 的本质
    经典Scout添加等时同步设备
    同步报故障解同步启动
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788898.html
Copyright © 2020-2023  润新知