• PAT (Advanced Level) Practice 1079 Total Sales of Supply Chain (25分) (DFS+map存储product)


    1.题目

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    K​i​​ ID[1] ID[2] ... ID[K​i​​]

    where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​10​​.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    

    Sample Output:

    42.4

     2.题目分析

    将处在同一深度的retailer的product使用DFS找到后累加到unordered_map中,最后遍历计算

    3.代码

    #include<iostream>
    #include<vector>
    #include<unordered_map>
    using namespace std;
    vector<int>lists[100001];
    int product[100001];
    unordered_map<int, int>deep;
    void DFS(int head,int times)
    {
    	if (lists[head].size() == 0)
    	{
    		deep[times] += product[head];
    	}
    	for (int i = 0; i < lists[head].size(); i++)
    	{
    		times++;
    		DFS(lists[head][i], times);
    		times--;
    	}
    }
    int main()
    {
    	int n,k,a;
    	double p, r;
    	scanf("%d %lf %lf", &n, &p, &r);
    	for (int i = 0; i < n; i++)
    	{
    		scanf("%d", &k);
    		if (k == 0)
    		{
    			scanf("%d", &a);
    			product[i] = a;
    			continue;
    		}
    		for (int j = 0; j < k; j++)
    		{
    			scanf("%d", &a);
    			lists[i].push_back(a);
    		}
    	}
    	DFS(0, 0);
    	double sum = 0;
    	double temp = p;
    	for (auto it = deep.begin(); it != deep.end(); it++)
    	{
    		temp = p;
    		for (int j = 0; j < it->first; j++)
    		{
    			temp = temp*(1 + r/100);
    		}
    		sum += temp*it->second;
    	}
    	printf("%.1f", sum);
    }
  • 相关阅读:
    PHP中获取当前页面的URL信息
    $_POST和$GLOBALS['HTTP_RAW_POST_DATA'] 的区别
    curl模拟ip和来源进行网站采集的实现方法
    mysql修改root密码的几种方法
    微信小程序实现支付功能
    git获取远程服务器的指定分支
    mysql函数技巧整理
    sql 查询目标数据库中所有的表以其关键信息
    SET NOCOUNT ON
    C# CultureInfo中常用的InvariantCulture
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788823.html
Copyright © 2020-2023  润新知