• AtCoder


    Problem Statement

    There are N piles of candies on the table. The piles are numbered 1 through N. At first, pile i contains ai candies.

    Snuke and Ciel are playing a game. They take alternating turns. Snuke goes first. In each turn, the current player must perform one of the following two operations:

    1. Choose a pile with the largest number of candies remaining, then eat all candies of that pile.
    2. From each pile with one or more candies remaining, eat one candy.

    The player who eats the last candy on the table, loses the game. Determine which player will win if both players play the game optimally.

    Constraints
    • 1N105
    • 1ai109
    Input

    The input is given from Standard Input in the following format:

    N
    a1 a2  aN
    
    Output

    If Snuke will win, print First. If Ciel will win, print Second.

    Sample Input 1
    2
    1 3
    
    Sample Output 1
    First
    

    At the beginning of the game, pile 2 contains the most candies. If Snuke eats all candies of this pile, Ciel has no choice but to eat the last candy.

    Sample Input 2
    3
    1 2 1
    
    Sample Output 2
    First
    

    If Snuke eats one candy from each pile, Ciel is again left with the last candy.

    Sample Input 3
    3
    1 2 3
    
    Sample Output 3
    Second

    (假设高度有序,从左到右递减)
    可以把问题转化成,初始在(0,0),有n个矩形拼成的凸多边形,第i个矩形是的左下角是(i-1,0),右上角是(i,h[i])。那么游戏就相当于每次只能向右或者向上走,不能走出多边形,问先手是否必胜。
    可以先画一画1*1的小正方形的情况,可以发现不论右上角是什么状态,左下角一定和它的状态一样 (右上角必败比较好发现,必胜的话要多画几个其他点的状态)。
    于是就可以直接暴力做了2333

    #include<bits/stdc++.h>
    #define ll long long
    using namespace std;
    const int N=100005;
    
    int a[N],n;
    bool sg;
    
    inline void solve(){
    	for(int i=1;i<=n;i++) if(i+1>a[i+1]){
    		for(int j=i+1;a[j]==i;j++) sg^=1;
    		sg|=(a[i]-i)&1,puts(sg?"First":"Second");
    		break;
    	}
    }
    
    int main(){
    	scanf("%d",&n);
    	for(int i=1;i<=n;i++) scanf("%d",a+i);
    	sort(a+1,a+n+1),reverse(a+1,a+n+1);
    	
    	solve();
    	
    	return 0;
    }
    

  • 相关阅读:
    Django----博客文章数据返回
    Django----admin模块初识
    Django搭建博客文章---模型层
    Js 提交 form 表单
    sql 查询 between and 和 >= <= 比较
    C# 未能加载项目文件
    不一样的 Null
    Js实现table单双行交替色
    C# 判断一个string型的时间格式是否正确
    利用 Label 小小的提升一下用户体验
  • 原文地址:https://www.cnblogs.com/JYYHH/p/9250505.html
Copyright © 2020-2023  润新知