• AC日记——Milking Grid poj 2185


    Milking Grid
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 8314   Accepted: 3586

    Description

    Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns. 

    Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below. 

    Input

    * Line 1: Two space-separated integers: R and C 

    * Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character. 

    Output

    * Line 1: The area of the smallest unit from which the grid is formed 

    Sample Input

    2 5
    ABABA
    ABABA
    

    Sample Output

    2
    

    Hint

    The entire milking grid can be constructed from repetitions of the pattern 'AB'.

    Source

     
     
    思路:
      每一列都给hash成一个值,然后横着kmp,找到最小循环节长度l1;
      每一行都给hash成一个值,然后竖着kmp,找到最小循环节长度l2;
      然后输出l1*l2;
      劳资re十多次,才发现题目里面是多组数据;
      然后又re十多次,看discuss才知道r和c的范围弄反了;
      气人简直、、、
     
     
    来,上代码:
    #include <cstdio>
    #include <cstring>
    #include <iostream>
    
    #define che 39
    #define mod 100000009LL
    #define mod1 100000007LL
    #define mod2 13000007LL
    
    using namespace std;
    
    int next[101],next_[100005],r,c,ans;
    
    long long t[101],p[100005];
    
    char ch[100005];
    
    int main()
    {
        while(scanf("%d%d",&r,&c)==2)
        {
            memset(t,0,sizeof(t));
            memset(p,0,sizeof(p));
            memset(next,0,sizeof(next));
            memset(next_,0,sizeof(next_));
            for(int i=1;i<=r;i++)
            {
                cin>>ch;
                for(int j=0;j<c;j++)
                {
                    t[j+1]=((t[j+1]*che)%mod+((ch[j]-'0')*che))%mod1;
                    p[i]=((p[i]*che)%mod+((ch[j]-'0')*che))%mod2;
                }
            }
            int i=0,j=1;next[0]=-1;
            while(j<=c)
            {
                if(i==0||t[i]==t[j]) next[j++]=i++;
                else i=next[i-1]+1;
            }
            i=0,j=1,next_[0]=-1;
            while(j<=r)
            {
                if(i==0||p[i]==p[j]) next_[j++]=i++;
                else i=next_[i-1]+1;
            }
            ans=(c-next[c])*(r-next_[r]);
            cout<<ans;
            putchar('
    ');
        }
        return 0;
    }
  • 相关阅读:
    一次有益的敏捷XP失败
    web拖动Drag&Drop原理
    一次有益的敏捷尝试
    一次有益的敏捷XP失败
    异地分布式敏捷软件开发探讨分析
    web拖动Drag&Drop原理
    XP中一些基本概念的简介
    XP中的重要惯例和规则
    异地分布式敏捷软件开发探讨分析
    PySide教程:第一个PySide应用
  • 原文地址:https://www.cnblogs.com/IUUUUUUUskyyy/p/6527637.html
Copyright © 2020-2023  润新知