• AC日记——Oulipo poj 3461


    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 37958   Accepted: 15282

    Description

    The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

    Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

    Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

    So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

    Input

    The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

    • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
    • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

    Output

    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

    Sample Input

    3
    BAPC
    BAPC
    AZA
    AZAZAZA
    VERDI
    AVERDXIVYERDIAN

    Sample Output

    1
    3
    0

    Source

     
     
    思路:
      不说了,说多了都是笑>.<;
     
     
    来,上代码:
    #include <cstdio>
    #include <string>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    
    using namespace std;
    
    int ls,lt,T,next[1000001];
    
    char s[1000001],t[1000001];
    
    inline void GetNext()
    {
        //memset(next,0,sizeof(next));
        int k=-1,j=0;
        next[j]=k;
        while(j<lt)
        {
            if(k==-1||t[j]==t[k])
            {
                k++,j++;
                next[j]=k;
            }
            else k=next[k];
        }
    }
    
    inline int Kmp()
    {
        GetNext();
        int i=0,j=0,return_=0;
        while(i<ls)
        {
            if(j==-1||s[i]==t[j]) i++,j++;
            else j=next[j];
            if(j==lt)
            {
                j=next[j];
                return_++;
            }
        }
        return return_;
    }
    
    int main()
    {
        scanf("%d",&T);
        for(int i=1;i<=T;i++)
        {
            cin>>t;
            cin>>s;
            ls=strlen(s);
            lt=strlen(t);
            cout<<Kmp()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    前端下载图片到本地
    小程序复制文本
    小程序的分享
    vue简单的父子组件之间传值
    git新的远程分支同步到本地
    C#使用RabbitMq队列(Sample,Work,Fanout,Direct等模式的简单使用)
    别再眼高手低了! 这些Linq方法都清楚地掌握了吗?
    Asp.NetCore 3.1 使用AutoMapper自动映射转换实体 DTO,Data2ViewModel
    .NetCore使用Redis,StackExchange.Redis队列,发布与订阅,分布式锁的简单使用
    core的 Linq基本使用,简单模拟数据库多表的左右内连接的测试
  • 原文地址:https://www.cnblogs.com/IUUUUUUUskyyy/p/6285663.html
Copyright © 2020-2023  润新知