• PTA——03-树2 List Leaves(25 分)【java语言实现】


    03-树2 List Leaves(25 分)

    题目

    Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

    Output Specification:

    For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

    Sample Input:

    8
    1 -
    - -
    0 -
    2 7
    - -
    - -
    5 -
    4 6

    Sample Output:

    4 1 5

    思路

    针对输入的数据:

    1) 构建二叉树
    2) 层次遍历,打印叶节点

    代码

    
    
    import java.util.*;
    
    class ThisTreeNode{
        int val;
        int left;
        int right;
    }
    
    public class Main {
        private static int[] check = new int[10];
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            ThisTreeNode[] T1 = new ThisTreeNode[10];
            int N =sc.nextInt();
            Arrays.fill(check, 0);
            int root =buildTree(sc,N,T1);
    
            //层次遍历二叉树,存储结点
    
            List<Integer> res = levelTraversal(root,T1);
    
            for (int i=0;i<res.size();i++){
                if (i!= res.size()-1){
                    System.out.print(res.get(i)+" ");
                }
                else
                    System.out.print(res.get(i));
            }
    
    
    
        }
    
        /**
         * 构建二叉树
         * @param sc
         * @param N
         * @param T
         * @return
         */
        private static int buildTree(Scanner sc,int N,ThisTreeNode[] T){
            for (int i=0;i<N;i++){
                T[i] = new ThisTreeNode();  //实例化很重要,否则会报空指针异常
                T[i].val = i;
                String left = sc.next();
                String right = sc.next();
                if(left.equals("-")){
                    T[i].left = -1;
                }else{
                    T[i].left = Integer.parseInt(left);
                    check[Integer.parseInt(left)] = 1;
                }
    
                if(right.equals("-")){
                    T[i].right = -1;
                }else{
                    T[i].right = Integer.parseInt(right);
                    check[Integer.parseInt(right)] = 1;
                }
            }
            int root = -1;
            for(int i=0;i<N;i++){
                if(check[i]==0){
                    root = i;
                }
            }
    
            return root;
        }
    /**
     * 层次遍历二叉树
     */
        private static List<Integer> levelTraversal(int root,ThisTreeNode[] T1){
            Queue<Integer> queue = new ArrayDeque<>();
    
            List<Integer> list = new ArrayList<>();
    
            queue.add(root);
    
            while ( queue.size()!=0){
    
                root = queue.poll();
    
                if (T1[root].left ==-1 && T1[root].right ==-1 )
                    list.add(root);
    
                 if (T1[root].left!=-1){
                    queue.offer(T1[root].left);
                }
    
                 if (T1[root].right!=-1){
                    queue.offer(T1[root].right);
                }
            }
    
            return list;
        }
    }
  • 相关阅读:
    BZOJ1513: [POI2006]Tet-Tetris 3D
    BZOJ3210: 花神的浇花集会
    BZOJ3207: 花神的嘲讽计划Ⅰ
    BZOJ3170: [Tjoi 2013]松鼠聚会
    BZOJ3747: [POI2015]Kinoman
    解题:POI 2008 Subdivision of Kingdom
    解题:JSOI 2007 重要的城市
    解题:USACO13NOV No Change
    解题:洛谷1120 小木棍
    解题:SCOI 2008 配对
  • 原文地址:https://www.cnblogs.com/HuanChen1025/p/8999276.html
Copyright © 2020-2023  润新知