• A1058 A+B in Hogwarts [进制转换]


    If you are a fan of Harry Potter, you would know the world of magic has its own currency system — as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

    Input Specification:

    Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

    Output Specification:

    For each test case you should output the sum of A and B in one line, with the same format as the input.

    Sample Input:
    3.2.1 10.16.27
    Sample Output:
    14.1.28

    题目大意:17个Sickle对换一个Galleon,29个Knut对换一个Sickle。根据Galleon.Sickle.Knut的方式相加A和B
    分析:像相加算术一样从后往前按位相加,处理好进位~

    #include<iostream>
    using namespace std;
    int main()
    {
    	int n1, n2, n3, n4, n5, n6, n7, n8, n9;
    	scanf("%d.%d.%d", &n1, &n2, &n3);
    	scanf("%d.%d.%d", &n4, &n5, &n6);
    	n9 = (n3 + n6) % 29;
    	int carry1=(n3 + n6) / 29;
    	n8 = (n2 + n5 + carry1) % 17;
    	int carry2 = (n2 + n5 + carry1) / 17;
    	n7 = carry2 + n1 + n4;
    	printf("%d.%d.%d", n7, n8, n9);
    }
    
  • 相关阅读:
    Erlang顺序型编程
    [转]理解gen_server behaviour
    [转]Parsing Text and Binary Files With Erlang
    [转]Running Hadoop On Ubuntu Linux (SingleNode Cluster)
    [转]erlang 监督树
    [转]Erlang之IO编程
    [转]分段表
    [转]如何“打败”CAP定理
    [转]A Millionuser Comet Application with Mochiweb
    [转]消息队列软件大比拼
  • 原文地址:https://www.cnblogs.com/Hsiung123/p/13812092.html
Copyright © 2020-2023  润新知