• A1073 Scientific Notation[字符串处理-科学计数法转普通数]


    思路借鉴柳神
    Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [±][1-9]”.”[0-9]+E[±][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.

    Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

    Input Specification:

    Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.

    Output Specification:

    For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

    Sample Input 1:

    +1.23400E-03

    Sample Output 1:

    0.00123400

    Sample Input 2:

    -1.2E+10

    Sample Output 2:

    -12000000000

    题目大意:题目给出科学计数法的格式的数字A,要求输出普通数字表示法的A,并保证所有有效位都被保留,包括末尾的0

    分析:n保存E后面的字符串所对应的数字,t保存E前面的字符串,不包括符号位。当n<0时表示向前移动,那么先输出0. 然后输出abs(n)-1个0,然后继续输出t中的所有数字;当n>0时候表示向后移动,那么先输出第一个字符,然后将t中尽可能输出n个字符,如果t已经输出到最后一个字符(j == t.length())那么就在后面补n-cnt个0,否则就补充一个小数点。 然后继续输出t剩余的没有输出的字符~
    —————————————————————————

    #include<iostream>
    #include<string>
    #include<cstring>
    using namespace std;
    int main()
    {
    	string s;
    	cin >> s;
    	int i = s.find('E');
    	string t = s.substr(1, i - 1);
    	int n = stoi(s.substr(i + 1));
    	if (s[0] == '-') cout << "-";
    	if (n < 0)
    	{
    		cout << "0.";
    		for (int j = 0; j < abs(n) - 1; j++)
    			cout << '0';
    		for (int j = 0; j < t.length(); j++)
    			if (t[j] != '.') cout << t[j];
    	}
    	else
    	{
    		cout << t[0]; int j, cnt;
    		for (j = 2,cnt=0; j < t.length()&&cnt<n; j++,cnt++)     //先输出数字,结束要cnt=n
    			cout << t[j];
    		if (j == t.length())
    		{		//数字输出完了,但cnt!=n,输出0
    			for (int k = 0; k < n - cnt; k++)
    				cout << "0";
    		}
    		else
    		{              //cnt=n 但数字没输出完全
    			cout << '.';
    			for (int k = j; k < t.length(); k++)
    				cout << t[k];
    		}
    	}
    	return 0;
    
    }
    
  • 相关阅读:
    JBPM 入门阅读
    Jquery ligerui下拉框复选,使下拉框中相应值对勾选中
    spring quartz 1.6配置方法
    断点续传的原理
    转:DWR详细应用介绍
    转:第一个DWR示例
    解决(CXF):SOAPFaultException: Fault occurred while processing
    s2sh保存错误: a different object with the same identifier value was already associated
    解决 java.lang.NoSuchMethodError: org.objectweb.asm.ClassVisitor.visit(IILjava/lang/String;Ljava/lan
    转载:struts2重要标签学习
  • 原文地址:https://www.cnblogs.com/Hsiung123/p/13812090.html
Copyright © 2020-2023  润新知