• POJ 2352 Stars【树状数组】


    Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    5
    1 1
    5 1
    7 1
    3 3
    5 5

    Sample Output

    1
    2
    1
    1
    0

    题意是说:若以每个start为标准,算出不在他的右边和不高于他的star的个数
    输入时x y是按照顺序的 而且还是统计数则想到树状数组,c[1...n]为x的次数,那么所求就是c[1]...c[x]的和

    (自认为优化了程序结果和没有优化的一样时间,还是贴简洁的代码吧)

    代码如下:

    #include<stdio.h>
    #include<string.h>
    #define n 32001 //n=32000时WA了N多次... 
    int c[n+5], total[n+5];
    int Lowbit(int t)  
    {
        return t&(t^(t-1)); 
    }
    int Sum(int end)   
    {
        int sum = 0;
        while(end > 0)
        {
            sum += c[end];
            end -= Lowbit(end);
        }
        return sum;
    }
    void add(int li, int val) 
    {
        while(li<=n)
        {
            c[li] += val;
            li += Lowbit(li);
        }
    } 
    int main()
    {
        int i, j, x, y, nn;
        scanf("%d", &nn); 
        memset(c, 0, sizeof(c)); 
        memset(total, 0, sizeof(total)); 
        for(i=1; i<=nn; i++)
        {
            scanf("%d%d", &x, &y);  //由于坐标x可能为0,因此输入坐标要+1,不然会超时0&(-0)=0; 
            add(x+1, 1);
            total[Sum(x+1)-1]++;
        }
        for(i=0; i<nn; i++)
            printf("%d\n", total[i]);
    }
  • 相关阅读:
    保证在浏览器上word/图片/Excel的下载的表现形式一样
    C学习笔记 知识集锦(二)
    函数返回值
    C++ 四种新式类型转换
    构造&析构
    指针与引用
    C++三大特性 封装 继承 多态
    Git stash 常见用法
    Git branch && Git checkout常见用法
    linux Vi使用
  • 原文地址:https://www.cnblogs.com/Hilda/p/2628426.html
Copyright © 2020-2023  润新知