• HDU 3496 Watch The Movie【二维背包】


    Problem Description
    New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
    DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
    But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
    How clever you are! Please help DuoDuo’s uncle.
     
    Input
    The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
    The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
    N: the number of DVD that DuoDuo want buy.
    M: the number of DVD that the shop can sale.
    L: the longest time that her grandfather allowed to watch.
    The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
     
    Output
    Contain one number. (It is less then 2^31.)
    The total value that DuoDuo can get tonight.
    If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
     
    Sample Input
    1 3 2 10 11 100 1 2 9 1
     
    Sample Output
    3
     

    思路

    二维背包中的简单套用模板即可。但是注意题目最后要求不能看完所有买的movie输出0,即初始化f[][]时要有些技巧设成无限小。若初始化为0会产生WA的情况。

    源码

    #include<stdio.h>

    #include<string.h>

    #include<iostream>

    using namespace std;

    int INF=0x3fffffff;

    int f[105][2000];

    int main()

    {

        int t, i, k, j, n, m, l;

        int time[105], vau[105];

        scanf("%d", &t);

        while(t--)

        {

            memset(time, 0, sizeof(time));

            memset(vau, 0, sizeof(vau));

            memset(f, 0, sizeof(f));

            scanf("%d%d%d", &n, &m, &l);

            for(i=1; i<=n; i++)

                scanf("%d%d", &time[i], &vau[i]);

            for(i=1;i<=m;i++)

                 for(j=0;j<=l;j++) f[i][j]=-INF;

            for(i=1; i<=n; i++)

                for(j=m; j>0; j--)

                    for(k=l; k>=time[i]; k--)

                        f[j][k]=max(f[j][k], f[j-1][k-time[i]]+vau[i]);

            if(f[m][l]<0)

                printf("0\n");

            else

                printf("%d\n", f[m][l]);

        }

    }

  • 相关阅读:
    SNP/单核苷酸多态性分析
    非链特异性转录组测序
    什么是转录因子?
    MEME(Motif-based sequence analysis tools)使用说明
    DNA binding motif比对算法
    序列比对那点事儿
    DNA motif 搜索算法总结
    Bioconductor简介
    什么是RNA-Seq (RNA Sequencing)
    TPM、read counts、RPKM/FPKM你选对了吗?
  • 原文地址:https://www.cnblogs.com/Hilda/p/2616955.html
Copyright © 2020-2023  润新知