• POJ 1745 Divisibility【DP】


    Language:
    Divisibility
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 8396   Accepted: 2909

    Description

    Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
    17 + 5 + -21 - 15 = -14 
    17 + 5 - -21 + 15 = 58 
    17 + 5 - -21 - 15 = 28 
    17 - 5 + -21 + 15 = 6 
    17 - 5 + -21 - 15 = -24 
    17 - 5 - -21 + 15 = 48 
    17 - 5 - -21 - 15 = 18 
    We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

    You are to write a program that will determine divisibility of sequence of integers. 

    Input

    The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
    The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

    Output

    Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

    Sample Input

    4 7
    17 5 -21 15

    Sample Output

    Divisible

    题意:给出n个数,在n个数中添加+,-号使得能整除k.

    思路:由于状态与前一个数有关,且和第i个数+或-有关。dp[i][j]表示第i个数余数为j时是否为真,dp[i][j-a[i]%m]=dp[i-1][j], dp[i][j+a[i]%m]=dp[i-1][j];判断dp[m][0]是否为真即可,初始条件是dp[1][a[1]]=1;但是注意一点下标不能为负数为此+k*n是等价的。

    代码如下:

    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    using namespace std;
    int dp[10005][105], a[10005];
    int main()
    {
    	int i, j, k, n;
    	while(scanf("%d%d", &n, &k)!=EOF)
    	{
    		memset(dp, 0, sizeof(dp));
    		memset(a, 0, sizeof(a));
    		for(i=1; i<=n; i++)
    		{
    			scanf("%d", &a[i]);
    			a[i]%=k;
    		}
    		while(a[1]<0)
    			a[1]+=k; 
    		dp[1][a[1]%k]=1; 
    		for(i=2; i<=n; i++)
    			 for(j=0; j<=k; j++)
    			 	if(dp[i-1][j])
    				{
    					int aa=j-a[i], bb=j+a[i]; 
    					while(aa<0)
    						aa+=k;
    					while(bb<0)
    						bb+=k; 
    					dp[i][aa%k]=1, dp[i][bb%k]=1;
    				} 
    		if(dp[n][0]==1)
    			printf("Divisible\n");
    		else
    			printf("Not divisible\n");
    	}
    } 

     

  • 相关阅读:
    android studio中timber的配置
    bufferknife框架的正确使用方式 -终于他么知道了
    开源的图像滤镜库----for Android
    HSV做通道分离是出现的Vector内存越界错误
    HSV与RGB的相互转换的公式
    Windows下python的第三方库的安装
    Python出现"Non-ASCII character 'xe6' in file"错误解决方法
    Verilog的IDE Quartus II
    Java-ZipUtil工具类
    Java-JDBCUtil工具类
  • 原文地址:https://www.cnblogs.com/Hilda/p/2616816.html
Copyright © 2020-2023  润新知