• nyoj 103-A+B Problem II (python 大数相加)


    103-A+B Problem II


    内存限制:64MB 时间限制:3000ms 特判: No
    通过数:10 提交数:45 难度:3

    题目描述:

    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

    A,B must be positive.

    输入描述:

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

    输出描述:

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. 

    样例输入:

    2
    1 2
    112233445566778899 998877665544332211

    样例输出:

    Case 1:
    1 + 2 = 3
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110

    python AC:

    n = int(input())
    for i in range(1, n + 1):  # 默认从0开始,后面那个数为不包括的数
        a, b = map(int, input().split())  # 实现两个值在同一行输入
        print("Case %d:" % i)
        print("%d + %d = %d" % (a, b, a + b))
        i += 1

    致谢

  • 相关阅读:
    luogu_1009 阶乘之和
    codevs_3117 高精度练习之乘法(my struct)
    luogu_2142 高精度减法
    luogu_1601 A+B Problem(高精)
    luogu_1007 独木桥
    luogu_1006 传纸条
    luogu_1004 方格取数
    luogu_1003 铺地毯
    luogu_1002 过河卒
    BZOJ 2560: 串珠子 (状压DP+枚举子集补集+容斥)
  • 原文地址:https://www.cnblogs.com/GetcharZp/p/9328517.html
Copyright © 2020-2023  润新知