• HDU 3496 Watch The Movie


    Watch The Movie

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others) Total Submission(s): 4532    Accepted Submission(s): 1426

    Problem Description
    New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep. DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end. But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L. How clever you are! Please help DuoDuo’s uncle.
     
    Input
    The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case: The first line is: N(N <= 100),M(M<=N),L(L <= 1000) N: the number of DVD that DuoDuo want buy. M: the number of DVD that the shop can sale. L: the longest time that her grandfather allowed to watch. The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
     
    Output
    Contain one number. (It is less then 2^31.) The total value that DuoDuo can get tonight. If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
     
    Sample Input
    1 3 2 10 11 100 1 2 9 1
     
    Sample Output
    3
     
    Source
     
    Recommend
    zhouzeyong
     
    思路:二维费用背包,相比一维背包而言,只需要增加一维即可
    状态转移方程:f[i][j][k] = max(dp[i - 1][j][k],dp[i - 1][j - p1][k - p2] + v);
     
    代码:
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    int dp[120][1020];
    int aaa[120];
    int bbb[120];
    int maxn;
    int t;
    int n,m,l;
    int main()
    {
        scanf("%d",&t);
        while(t --)
        {
            maxn = 0;
            scanf("%d%d%d",&n,&m,&l);
            memset(aaa,0,sizeof(aaa));
            memset(bbb,0,sizeof(bbb));
            memset(dp,0x80,sizeof(dp));
            dp[0][0] = 0;
            for(int i = 1;i <= n;i ++)
                scanf("%d%d",&aaa[i],&bbb[i]);
            for(int i = 1;i <= n;i ++)
               for(int j = m;j >= 1;j --)
                  for(int k = l;k >= aaa[i];k --)
                  {
                      dp[j][k] = max(dp[j][k],dp[j - 1][k - aaa[i]] + bbb[i]);
                  }
            for(int k = 0;k <= l;k ++)
                if(dp[m][k] > maxn)
                     maxn = dp[m][k];
            printf("%d ",maxn);
        }
        return 0;
    }
  • 相关阅读:
    Nginx配置简单说明
    JVM需要知道的一些设置参数
    Maven仓库(私服)中上传第三方jar包
    maven本地资源库设置
    sweetalert2使用教程
    《算法导论》学习笔记——二叉搜索树
    散列表
    跨域请求
    mvn常用命令
    Springmvc配置笔记
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3332410.html
Copyright © 2020-2023  润新知