A Knight's Journey
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 26188 | Accepted: 8942 |
Description
Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Problem Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
Source
TUD Programming Contest 2005, Darmstadt, Germany
思路:简单DFS,但是第一次接触字典序啊,A1的位置搜索第一次得到的路径一定就是答案
证明正在进行中
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int map[30][30];
int hash[30][30];
int n,m,t;
int flag;
int move[8][2] = {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
void DFS(int x,int y,int sqshu)
{
//printf("%d %d have %d ",x,y,hash[x][y]);
if(flag == 1)
return ;
if(hash[x][y] == sqshu)
{
flag = 1;
return ;
}
for(int i = 0;i < 8;i ++)
{
if(!map[x + move[i][0]][y + move[i][1]] &&
(x + move[i][0]) >= 1 && (x + move[i][0]) <= n
&& (y + move[i][1]) >= 1 && (y + move[i][1]) <= m)
{
map[x + move[i][0]][y + move[i][1]] = 1;
hash[x + move[i][0]][y + move[i][1]] = hash[x][y] + 1;
DFS(x + move[i][0],y + move[i][1],sqshu);
map[x + move[i][0]][y + move[i][1]] = 0;
if(flag == 0)
{
hash[x + move[i][0]][y + move[i][1]] = 0;
}
if(flag == 1)
return;
}
}
return ;
}
int main()
{
scanf("%d",&t);
for(int l = 1;l <= t;l ++)
{
scanf("%d%d",&n,&m);
printf("Scenario #%d: ",l);
memset(hash,0,sizeof(hash));
memset(map,0,sizeof(map));
flag = 0;
hash[1][1] = 1;
map[1][1] = 1;
DFS(1,1,n * m);
if(flag == 0)
printf("impossible ");
else
{
for(int k = 1;k <= n * m;k ++)
{
for(int i = 1;i <= n;i ++)
for(int j = 1;j <= m;j ++)
{
if(hash[i][j] == k)
printf("%c%d",j + 'A' - 1,i);
}
}
printf(" ");
}
printf(" ");
}
return 0;
}
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int map[30][30];
int hash[30][30];
int n,m,t;
int flag;
int move[8][2] = {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
void DFS(int x,int y,int sqshu)
{
//printf("%d %d have %d ",x,y,hash[x][y]);
if(flag == 1)
return ;
if(hash[x][y] == sqshu)
{
flag = 1;
return ;
}
for(int i = 0;i < 8;i ++)
{
if(!map[x + move[i][0]][y + move[i][1]] &&
(x + move[i][0]) >= 1 && (x + move[i][0]) <= n
&& (y + move[i][1]) >= 1 && (y + move[i][1]) <= m)
{
map[x + move[i][0]][y + move[i][1]] = 1;
hash[x + move[i][0]][y + move[i][1]] = hash[x][y] + 1;
DFS(x + move[i][0],y + move[i][1],sqshu);
map[x + move[i][0]][y + move[i][1]] = 0;
if(flag == 0)
{
hash[x + move[i][0]][y + move[i][1]] = 0;
}
if(flag == 1)
return;
}
}
return ;
}
int main()
{
scanf("%d",&t);
for(int l = 1;l <= t;l ++)
{
scanf("%d%d",&n,&m);
printf("Scenario #%d: ",l);
memset(hash,0,sizeof(hash));
memset(map,0,sizeof(map));
flag = 0;
hash[1][1] = 1;
map[1][1] = 1;
DFS(1,1,n * m);
if(flag == 0)
printf("impossible ");
else
{
for(int k = 1;k <= n * m;k ++)
{
for(int i = 1;i <= n;i ++)
for(int j = 1;j <= m;j ++)
{
if(hash[i][j] == k)
printf("%c%d",j + 'A' - 1,i);
}
}
printf(" ");
}
printf(" ");
}
return 0;
}