• HDU 2727 Catch That Cow


    Catch That Cow

    Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5457    Accepted Submission(s): 1740

    Problem Description
    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
    * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
    If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
     
    Input
    Line 1: Two space-separated integers: N and K
     
    Output
    Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
     
    Sample Input
    5 17
     
    Sample Output
    4
    Hint
    The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
     
    Source
     
    Recommend
    teddy
     
    思路:BFS + 剪枝,我是一坑货,剪枝只会皮毛
     
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <queue>
    using namespace std;
    int
    n,k;
    int
    map[100010];
    struct
    Node
    {

        int
    x;
        int
    step;
        bool
    operator < (const Node &t) const
         {

               return
    t.step < step;
         }
    }
    info;
    int
    BFS()
    {

        priority_queue < Node > q;
        info.x = n;
        info.step = 0;
        q.push(info);
        map[info.x] = 1;
        while
    (!q.empty())
        {

            Node boss;
            boss = q.top();
            q.pop();
            if
    (boss.x == k)
                return
    boss.step;
            int
    a = boss.x;
            int
    step = boss.step;
            //printf("%d              %d ",a,step);
            if(a * 2 <= 100000 && a < k && map[a * 2] == 0)
            {

                    info.x = a * 2;
                    info.step = step + 1;
                    q.push(info);
                    map[info.x] = 1;
                    //printf("%d   %d ",info.x,info.step);
                    if(info.x == k)
                        return
    info.step;
            }

            if
    (a - 1 >= 0 && map[a - 1] == 0)
            {

                    info.x = a - 1;
                    info.step = step + 1;
                    q.push(info);
                    map[info.x] = 1;
                    //printf("%d   %d ",info.x,info.step);
                    if(info.x == k)
                        return
    info.step;
            }

            if
    (a + 1 <= 100000 && map[a + 1] == 0)
            {

                    info.x = a + 1;
                    info.step = step + 1;
                    q.push(info);
                    map[info.x] = 1;
                    //printf("%d   %d ",info.x,info.step);
                    if(info.x == k)
                        return
    info.step;
            }
        }
    }

    int
    main()
    {

            while
    (~scanf("%d%d",&n,&k))
            {

                  memset(map,0,sizeof(map));
                  printf("%d ",BFS());
            }
    }
  • 相关阅读:
    校验文件数字签名的合法性(VerifyPE)
    windbg help
    VIM的常用操作
    使用Jsonp解决跨域数据访问问题
    Linux下不同文件编码的转换
    Segoe Font 介绍
    关于框架的一些思考
    Linux下Aptana Plugin For Eclipse的破解
    增强网站易用性的10个设计技巧
    Firebug中的console tab使用总结
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3283600.html
Copyright © 2020-2023  润新知