• HDU 2952 胜利大逃亡


    胜利大逃亡

    Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 65   Accepted Submission(s) : 16

    Font: Times New Roman | Verdana | Georgia

    Font Size:

    Problem Description

    Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.
    魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
     

    Input

    输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)
    特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

    Output

    对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

    Sample Input

    1
    3 3 4 20
    0 1 1 1
    0 0 1 1
    0 1 1 1
    1 1 1 1
    1 0 0 1
    0 1 1 1
    0 0 0 0
    0 1 1 0
    0 1 1 0
    

    Sample Output

    11
    

    Author

    Ignatius.L
     
    思路:这个题其实就是一个普通的广度优先搜索,只不过立体感较强,容易失误,我WA了几次
     
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    using namespace std;
    int
    hash[52][52][52];
    int
    map[52][52][52];
    int
    k;
    int
    timee;
    int
    a,b,c,t;
    int
    bfs[6][3] = {1,0,0,-1,0,0,0,1,0,0,-1,0,0,0,1,0,0,-1};
    struct
    Node
    {

        int
    x,y,z;
        int
    time;
    };

    int
    BFS()
    {

        queue <Node> q;
        Node top;
        top.x = 0;top.y = 0;top.z = 0;top.time = 0;
        q.push(top);
        timee = -1;
        while
    (!q.empty())
        {

            Node temp;
            temp = q.front();
            q.pop();
            if
    (temp.x == (a - 1) && temp.y == (b - 1) && temp.z == (c - 1))
            {

               
               timee = temp.time;
               break
    ;
            }

            for
    (int i = 0;i < 6;i ++)
            {

                int
    x = temp.x + bfs[i][0];
                int
    y = temp.y + bfs[i][1];
                int
    z = temp.z + bfs[i][2];
                int
    time = temp.time;
                if
    (hash[x][y][z] == 0 && map[x][y][z] == 0
                &&
    x >= 0 && x < a && y >= 0 && y < b
                &&
    z >= 0 && z < c)
                {

                    Node xin;
                    xin.x = x;xin.y = y;xin.z = z;
                    xin.time = time + 1;
                    q.push(xin);
                    hash[x][y][z] = 1;
                }
            }
        }

        return
    timee;
    }

    int
    main()
    {

        scanf("%d",&k);
        while
    (k --)
        {

            memset(hash,0,sizeof(hash));
            scanf("%d%d%d%d",&a,&b,&c,&t);
            for
    (int i = 0;i < a;i ++)
               for
    (int j = 0;j < b;j ++)
                  for
    (int k = 0;k <c;k ++)
                     scanf("%d",&map[i][j][k]);
            hash[0][0][0] = 1;
               int
    step = BFS();
               if
    (step < t)
                    printf("%d ",step);
               else

                    printf("-1 ");   
        }
    }
  • 相关阅读:
    MacOS Mojave启动U盘制作及安装方法详细介绍
    Boostnote for Mac——如何使用TeX精美地编写数学公式
    pycharm pro 2019 mac如何重构?
    Understand教程—使用搜索功能的几种方法
    Understand Mac项目视图初级使用
    文本代码编辑CudaText for Mac使用方法
    java学习笔记之面向对象接口
    java学习笔记之遍历ArrayList的三种方法
    java学习笔记之面向对象static,final关键字
    java学习笔记之eclipse下jar包导入
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3283514.html
Copyright © 2020-2023  润新知