• POJ 2367:Genealogical tree(拓扑排序模板)


    Genealogical tree

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7285   Accepted: 4704   Special Judge

    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
    And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
    Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    5
    0
    4 5 1 0
    1 0
    5 3 0
    3 0
    

    Sample Output

    2 4 5 3 1

    Source

    Ural State University Internal Contest October'2000 Junior Session

    题意:有n个人,编号1~n,然后输入n行,第i行有一些编号,这些编号代表第i个人的后代,每行输入以0结束。然后按照辈分输出这些编号

    题并不难,拓扑排序的模板题,但是输出格式有点坑

    AC代码:

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x3f3f3f3f
    const double E=exp(1);
    const int maxn=1e3+10;
    using namespace std;
    int a[maxn][maxn];
    int vis[maxn];
    int n;
    void toposort()
    {
    	for(int i=1;i<=n;i++)
    	{
    		for(int j=1;j<=n;j++)
    		{
    			if(vis[j]==0)
    			{
    				vis[j]--;
    				cout<<j;
    				for(int k=1;k<=n;k++)
    				{
    					if(a[j][k]==1)
    					{
    						a[j][k]--;
    						vis[k]--;
    					}
    				}
    				if(i!=n)
    					cout<<" ";
    				break;
    			}
    			
    		}
    		if(i==n)
    			cout<<endl;
    	}
    }
    int main(int argc, char const *argv[])
    {
    	cin>>n;
    	ms(a);
    	ms(vis);
    	int x;
    	for(int i=1;i<=n;i++)
    	{
    		for(int j=1;;j++)
    		{
    			scanf("%d",&x);
    			if(x==0)
    				break;
    			a[i][x]=1;
    			vis[x]++;
    		}
    	}
    	toposort();
    	return 0;
    }
    
  • 相关阅读:
    通过WCF引用ListData.svc查询,更新数据
    SharePoint2010 BCS搜索结果的标题
    多个Finder方法的外部内容类型
    SharePoint 2010 中的BCS身份验证模式
    使用Visual Studio工作流发布SharePoint网页
    PerformancePoint Services故障排除
    使用SharePoint 2010模式对话框
    在自定义字段类型的CAML中使用AJAX jQuery
    扩展Visual Studio 2010服务器资源管理器中的SharePoint结点
    BCS配置文件页、爬网与搜索
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324448.html
Copyright © 2020-2023  润新知