• Find a way HDU


    Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
    Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
    Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

    InputThe input contains multiple test cases. 
    Each test case include, first two integers n, m. (2<=n,m<=200). 
    Next n lines, each line included m character. 
    ‘Y’ express yifenfei initial position. 
    ‘M’    express Merceki initial position. 
    ‘#’ forbid road; 
    ‘.’ Road. 
    ‘@’ KCF 
    OutputFor each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.Sample Input

    4 4
    Y.#@
    ....
    .#..
    @..M
    4 4
    Y.#@
    ....
    .#..
    @#.M
    5 5
    Y..@.
    .#...
    .#...
    @..M.
    #...#

    Sample Output

    66
    88
    66
    #include<iostream>
    #include<sstream>
    #include<algorithm>
    #include<cstdio>
    #include<string.h>
    #include<string>
    #include<cmath>
    #include<cmath>
    #include<vector>
    #include<stack>
    #include<queue>
    #include<map>
    #include<set>
    using namespace std;
    const int INF=204;
    const int M=0x1f1f1f1f;
    int n,m,z;
    char cnt[INF][INF];
    int dir[][2]={{1,0},{0,-1},{-1,0},{0,1}};
    int dis[INF][INF][2];
    int vis[INF][INF];
    struct Node{
        int x,y,step;
        Node(int x,int y,int z):x(x),y(y),step(z){}
        Node(){}
    };
    void bfs(int x,int y){
        memset(vis,0,sizeof(vis));
        vis[x][y]=1;
        queue<Node>q;
        q.push(Node(x,y,0));
        while(!q.empty()){
            Node u=q.front();
            q.pop();
            for(int i=0;i<4;i++){
                int tx=u.x+dir[i][0];
                int ty=u.y+dir[i][1];
                if(!vis[tx][ty]&&tx>=1&&tx<=n&&ty>=1&&ty<=m&&cnt[tx][ty]!='#'){
                    vis[tx][ty]=1;
                    dis[tx][ty][z]=u.step+1;
                    q.push(Node(tx,ty,u.step+1));
                }
            }
        }
    }
    int main(){
        while(cin>>n>>m){
            for(int i=0;i<2;i++){
                for(int j=1;j<=n;j++){
                    for(int k=1;k<=m;k++)
                    dis[j][k][i]=M;
                }
            }
            for(int i=1;i<=n;i++)
            scanf("%s",cnt[i]+1);
            for(int i=1;i<=n;++i)
            for(int j=1;j<=m;j++){
                if(cnt[i][j]=='Y'){
                    z=1;
                    bfs(i,j);
                }
                if(cnt[i][j]=='M'){
                    z=0;
                    bfs(i,j);
                }
            }
            int ans=M;
            for(int i=1;i<=n;i++){
                for(int j=1;j<=m;j++){
                    if(cnt[i][j]=='@'){
                        //去同一家KFC的距离之和 
                        ans=min(ans,dis[i][j][0]+dis[i][j][1]);
                    }
                }
            }
            cout<<ans*11<<endl;
        }
    }
  • 相关阅读:
    Win32中安全的子类化(翻译)
    OJ题目JAVA与C运行效率对比
    关协同过滤
    Objective-C ,ios,iphone开发基础:使用第三方库FMDB连接sqlite3 数据库,实现简单的登录
    GDI+简单现实文字旋转
    opencv 2.46与visual studio 2012 配置方法
    Emacs助力PowerShell
    ARC forbids explicit message send of 'autorelease'错误
    Event处理
    复制中发布服务器和订阅服务器内容不一致的解决办法
  • 原文地址:https://www.cnblogs.com/CuteAbacus/p/9492221.html
Copyright © 2020-2023  润新知